Support » Plugin: Advanced Forms for ACF » Compatibility issue with ACF 5.7?

  • Resolved owen821202

    (@owen821202)


    Just an FYI – I updated both ACF & advanced forms to their latest releases & when adding a new form or editing an existing one ALL acf meta boxes are visible on the page and all stuck in a continual loading state… For now I have downgraded acf to 5.6.10 and the issue goes away…

    Otherwise loving this plugin! – finally a solution that fits with acf and means I can build my own form templates that don’t rely on ninja forms 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • I had this issue and clearing my local browser cache cleared the issue up, worth trying that.

    Plugin Author fabianlindfors

    (@fabianlindfors)

    Hi! I’m glad you’re enjoying AF!
    I have done some testing with ACF 5.7 but haven’t run into the issue you’re experiencing.
    Could you try James suggestion?

    Thanks!

    Also having issues here… Have the latest ACF Pro and advanced forms (free version) running and I am unable to attache images to a custom post type.

    I tried doing some debugging specifically in af_save_all_fields($post_id) since i thought that might be where incoming POST data is generally attached to the WordPress post.

    I disabled all other plugins to remove any suspects. Any ideas on what I can poke at to help resolve the issue?

    Plugin Author fabianlindfors

    (@fabianlindfors)

    Hi!

    Are you using the regular image field? Are you having an issue with the image not being saved properly? 🙂

    This isn’t 100% related, but it does concern 5.7 compatibility. I’m trying to use the “Pages” field and getting a bunch of JavaScript errors. Here’s what I’m seeing:

    assets/js/forms.js
    163: acf.validation.toggle( form.$el, 'lock' );

    No longer a function. Replacing it with acf.validation.lockForm(form.$el); works. In fact, the entire validatePage method is broken with ACF’s JS overhall from 5.7 (you’ll see so many methods removed/streamlined in acf-input.js). Replacing the whole thing with acf.validation.fetch( { form: form.$el, complete: callback() } ); seems to be working, but I don’t know enough about either plugin to know if this is a solution.

    Anyway, fantastic plugin! After fighting with so many contact forms and loving ACF, this is exactly what I was hoping for.

    Plugin Author fabianlindfors

    (@fabianlindfors)

    I’m working on a fix for the issue with paged forms. Hope to have one ready soon!

    Thank you for your patience and help 🙂

    Hey Fabian,

    Thanks for the response. I’m using the standard image field. The image is uploaded to wordpress and shows in media but it’s never attached to the post. Use to work just fine but I’m unable to see where the breaking change came in.

    Plugin Author fabianlindfors

    (@fabianlindfors)

    Hello again everybody!

    I think I’ve fixed most of the issue you’ve been experiencing with the new 1.5.2 release. It includes a fix for the Javascript issues with ACF 5.7 as well as a fix for the image/file fields. Please try updating and see if everything works as expected.

    Thank you so much for your help troubleshooting! 🙂

    Thread Starter owen821202

    (@owen821202)

    Hi Fabian, sorry for the delayed response, I’ve been on holiday…
    I have updated both to ACF 5.7.1 & AF to 1.5.2 – emptied the browser cache for good measure and it all works perfectly for me, thanks for everyone’s efforts 🙂

    Plugin Author fabianlindfors

    (@fabianlindfors)

    Makes me happy to hear!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Compatibility issue with ACF 5.7?’ is closed to new replies.