Support » Plugin: W3 Total Cache » Compatibility check and server configuration

  • Resolved crazy_cat

    (@crazy_cat)


    Hi, the compatibility check says that some mod… are not detected (see below). The support from my server says:

    the mod _… are not found because PHP FPM and not MOD_PHP is used. However, I can assure you that the mods are on and via the .htaccess file e.g. can be addressed.

    Is there something else I must do now? So… does it work or not?

    mod_deflate: Not detected (required for disk enhanced Page Cache and Browser Cache)
    mod_env: Not detected (required for disk enhanced Page Cache and Browser Cache)
    mod_expires: Not detected (required for disk enhanced Page Cache and Browser Cache)
    mod_filter: Not detected (required for disk enhanced Page Cache and Browser Cache)
    mod_ext_filter: Not detected (required for disk enhanced Page Cache and Browser Cache)
    mod_headers: Not detected (required for disk enhanced Page Cache and Browser Cache)
    mod_mime: Not detected (required for disk enhanced Page Cache and Browser Cache)
    mod_rewrite: Not detected (required for disk enhanced Page Cache and Browser Cache)
    mod_setenvif: Not detected (required for disk enhanced Page Cache and Browser Cache)

Viewing 4 replies - 1 through 4 (of 4 total)
  • Edit: Also following message shows up in the dashboard:

    Either the PHP configuration, web server configuration or a script in the WordPress installation has zlib.output_compression enabled.
    Please locate and disable this setting to ensure proper HTTP compression behavior.

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @crazy_cat

    Thank you for your inquiry and I am happy to assist you with this.
    Your hosting support is right. Not detected means you don’t use mod_php mode, so you probably use PHP-fpm. We cannot detect Apache modules in that case, but that doesn’t mean it is not installed/active. And as hosting support stated those modules are enabled.
    As for the zlib.output You may want to check your /etc/php.ini file and/or contact your hosting provider to make sure that setting has not been enabled by default or added by any other plugin.
    You can also try adding ini_set('zlib.output_compression', 0); to the wp-config file works best, or adding zlib.output_compression = off to php.ini
    Also, make sure to check your .htacces/nginx for php_flag zlib.output_compression on.
    Thank you!

    Thanks for the answer. But what I really want to know: Does everything work now, even if the compatibility check says no?

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @crazy_cat

    Yes as I stated in the previous post and as your hosting support confirmed, even if the compatibility check says no it does not mean the modules are note activated so everything should be working as expected.
    Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.