Support » Plugins and Hacks » Compatibility between W3TC Cloudflare and Cloudfront

  • Resolved sadujsaint

    (@sadujsaint)


    I can’t imagine this is a particularly rare problem but having looked high and low I can’t seem to find a solution to the following problem.

    I am running the wonderful W3TC with a variety of caching options enabled and using the inbuilt functionality to enable both my CDN (Amazon Cloudfront on Origin Push) and Cloudflare.

    A dream set-up you might think, and so did I for a couple of hours. 3 hours later and suddenly no content was coming through from Cloudfront. I tried a couple of different set-ups and nothing seems to work. I disabled CDN within W3TC and everything is fine and back to normal (minus CDN), but the moment I enable it I am missing whatever files I stipulate it to handle.

    Question:

    Is Amazon Cloudfront incompatible with the plugin or Cloudflare itself?
    And has anyone else encountered this problem – I can’t be the only one to have tried this set-up?
    Is there a fix at Cloudfronts end?

    Thanks in advance for your time – any ideas?

Viewing 2 replies - 1 through 2 (of 2 total)
  • This issue has been resolved thanks to the team at Cloudflare who couldn’t have been more helpful.

    They talked me through potential solutions and within a couple of hours we had it up and running – very impressive indeed.

    Ok, great.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Compatibility between W3TC Cloudflare and Cloudfront’ is closed to new replies.