Support » Plugin: WooCommerce Sermepa payment gateway » Compatibilidad con SNI

  • Resolved josearagones

    (@josearagones)


    Hola buenas.

    Tengo dos preguntas:

    1) El plugin oficial tiene un problema y es que si en la ventana del TPV el cliente vuelve atrás o recarga, el TPV le da fallo por pedido duplicado. ¿Este plugin solventa eso?

    2) Por cómo está configurado mi server compartido el plugin tiene que funcionar con SNI. Entiendo que simplemente indicándole que funcione con HTTP ya debería conectarse aunque la web esté con un SSL SNI. ¿Es así? ¿Necesito hacer algo más?

    Muchas gracias y saludos.
    Jose

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author jesusangel.delpozo

    (@jesusangeldelpozo)

    Hola.

    Respecto a la primera pregunta, lamentablemente mi plugin tiene el mismo problema. Aunque el número de pedido es hace aleatorio añadiendo varios dígitos antes de enviarlo al TPV, si el usuario pulsa el botón para volver atrás lo que hace es volver a cargar el formulario preparado anteriormente para enviar los datos a REDSYS, con el mismo número de pedido que antes. Le daré una vuelta para ver si lo puedo resolver de alguna forma adecuada.

    Y respecto a la segunda, el problema del SNI es que la pasarela de REDSYS no lo soporta y por tanto no recibirás las notificaciones de los pagos y los pedidos se quedarán pendientes. En la configuración del plugin tienes una opción llamada “Protocolo para notificaciones” en la que puedes seleccionar la forma en la que recibes estas: Automático (si la página está sobre HTTPS la notificación llega a través de ese mismo protocolo y si está sobre HTTP lo mismo), HTTP para forzar a que las notificaciones lleguen por HTTP y HTTPS para lo contrario.

    Si tu hosting comparte la IP y tiene que funcionar con SNI, deberás seleccionar la opción de notificar vía HTTP y permitir las conexiones desde la pasarela de REDSYS a través de este protocolo. Si permites navegar por tu sitio sin usar HTTPS, no tendrás que hacer nada. Si fuerzas a los usuarios a conectar siempre vía HTTPS (con alguna redirección) entonces tendrás que añadir una exclusión para la página de las notificaciones.

    Saludos cordiales.

    Plugin Author jesusangel.delpozo

    (@jesusangeldelpozo)

    La URL a la cual deberás aplicar la excepción para permitir su consulta vía HTTP tiene la forma siguiente:

    http://tusitioweb.tudominio/?wc-api=WC_MyRedsys

    Thread Starter josearagones

    (@josearagones)

    Muchísimas gracias Jesús Ángel.

    Cachis. Lo de los pagos es mala cosa porque aunque lo normal sería que la compra fuese lineal, es alucinante la de gente que echa atrás para comprobar yoqueséqué, o que recarga la página… sobre todo en móviles. No tiene sentido pero es así.

    En prestashop cuando implementaron el encriptado a 256 puse el módulo oficial sin saber que pasaba esto y en 4 días me di cuenta que los abandonos de carrito se habían ido de madre.

    Lo del SNI es una pirula que acabo de descubrir en mi nuevo hosting. Yo hasta ahora tenía una IP privada y un SSL de rapidSSL. Pero en el server nuevo tienen todos los servidores compartidos configurados para SNI para poder poner Let’s Encrypt, y me han dicho que aunque pille una ip privada y un SSL comprado, el redsys va a pillar el servidor como SNI y no me va a dejar funcionar en HTTPS. De broma.

    Ya contaré cómo lo soluciono.

    Saludos.
    Jose

    Plugin Author jesusangel.delpozo

    (@jesusangeldelpozo)

    Sí. La pasarela de REDSYS no soporta SNI por el momento. Lo puedes hacer como te dije, configurando el plugin para que la notificación del pago se haga mediante HTTP y permitiendo la consulta mediante HTTP a la URL http://tusitioweb.tudominio/?wc-api=WC_MyRedsys

    David_

    (@david_peris)

    Hola!

    Yo tengo el mismo problema con Redsys ya que utilizo Let’s Encrypt. He instalado tu plugin y marcado el protocolo de notificaciones en HTTP como explicas.
    Lo que no me queda claro es como añadir la excepción de consulta mediante HTTP a la url http://www.midominio.com/?wc-api=WC_MyRedsys.
    En Redsys notifica un error 403 para esta misma url. He probado a añadir este código en el .htacess, pero no soluciona nada.
    RewriteCond %{HTTPS} on
    RewriteCond %{REQUEST_URI} ^/http://www.midominio.com/?wc-api=WC_MyRedsys
    RewriteRule ^(.*)$ http://%{HTTP_HOST}/$1 [R=301,L]

    Alguna idea? Muchas gracias!
    David

    Thread Starter josearagones

    (@josearagones)

    Pégale un vistazo a las recomendaciones que da esta gente de Codection para su plugin de pago. Al venir los problemas de la conexión Redsys-Wordpress van a ser los mismos.

    https://codection.com/redsys-gateway-for-woocommerce-pro-problemas-frecuentes-al-configurar/

    Lo más habitual es que haya un conflicto con algún módulo de seguridad de tu instalación o de tu hosting y esté cortando la llamada de confirmación.

    Saludos.

    Plugin Author jesusangel.delpozo

    (@jesusangeldelpozo)

    @david_peris

    En el código que has puesto hay varios errores. Primero, la condición RewriteCond %{HTTPS} on no tiene sentido, porque la conexión te va a llegar por HTTP. Y luego, tienes que sustituir lo de http://www.midominio.com por el tuyo, y ajustar la regla para que coincida con el patrón indicado.

    Saludos cordiales.

    David_

    (@david_peris)

    Muchas gracias por la info Jose y Jesús!

    Finalmente está solucionado. Era cuestión de desactivar Cloudfare.

    Y enhorabuena por el plugin Jesús.

    Saludos,

    David

    User

    (@whitelionstudio)

    Tenia el error de pedido pendiente de pago con error 503 en tpv. he desactivado All in one seo pack y todo funciona bien. Por si le sirve a alguien.
    No he descargado tu plugin @jesusangeldelpozo pero sin duda para la próxima tienda online lo compro y me quito de problemas.

    Plugin Author jesusangel.delpozo

    (@jesusangeldelpozo)

    Estimado Manu.

    El plugin es gratis, aunque si quieres puedes hacer una donación a través de PayPal.

    Saludos cordiales.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Compatibilidad con SNI’ is closed to new replies.