Support » Plugin: Enhanced Author Dropdown » Compatability with 3.9 or MU?

Viewing 11 replies - 1 through 11 (of 11 total)
  • I’ve done some experimenting and it seems to work in both MU and 3.9, however it doesn’t work for download post types in Easy Digital Downloads even though it’s enabled for such. Any ideas?

    Plugin Author chriscct7

    (@chriscct7)

    By default, EDD doesn’t enable authors for the download post type, which is why there isn’t a dropdown on the download post type.

    Thanks, Chris… unfortunately, they sent me your way, er, this way to solve my issue of changing the author of the download. There doesn’t appear to be any way?? Any suggestions?

    Plugin Author chriscct7

    (@chriscct7)

    Who sent you over here?
    I’m also one of EDD’s core developers and support agents 😉

    Do you have a ticket somewhere on EDD’s site?

    Sorry Chris, I made a mistake. IT’s getting confusing between the plugin developers, EDD, and the Astoundify guys that make the theme. The suggestion came from Spencer at Astoundify, sorry (makers of the plugin). Just got confused!

    So should I open a ticket at the EDD site? I’ve spent almost $300 or so (maybe more) in the last week in plugins. Love the software, but it’s hard tracking down the last few things we need. 🙂

    Plugin Author chriscct7

    (@chriscct7)

    It’s not a problem. No need to open a ticket, I just wanted to get all of the EDD team members on the same page here.

    Are you using FES on your site, or how are you adding author support to EDD?

    No, we’re not using FES (yet), I just need to change the authors so instead of an individual user, they can come from our “company”, as well as change the sample template downloads that we imported via XML to non-EDD/appthemer names. I realize I could do this manually by recreating the downloads from a new account, but I figured there was a smarter way. Maybe not?

    Plugin Author chriscct7

    (@chriscct7)

    Okay, so EDD by default doesn’t have author support. FES adds it, but since you aren’t using that, there’s no dropdown. You’ll need to put this (minus the backticks if you’re reading this on email as opposed to viewing the forum) in your theme’s function.php file.

    add_filter('edd_download_supports', 'edd_download_supports_authors');
    function edd_download_supports_authors($supports){
    return array( 'title', 'editor', 'thumbnail', 'excerpt', 'author' );
    }

    Chris you rock…! Thank you so much. I’d like to send you something as a show of my appreciation for this and EDD in general, can you PM me? I don’t see how to mark a message as private.

    Plugin Author chriscct7

    (@chriscct7)

    WordPress.org doesn’t support PM’s but you can always contact me via my site at chriscct7.com/contact or hello@chriscct7.com

    Email Sent Chris!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Compatability with 3.9 or MU?’ is closed to new replies.