Support » Plugin: Wordfence Security » comparison with out-of-date core files

  • hey,
    i dunno what version wordfence compares the core files with, but it seems to be outdated

    the core file wordfence uses:

    4338	    * @since 3.1.0
    4339	    *
    4345	   return apply_filters( 'get_ancestors', $ancestors, $object_id, $object_type );

    the actual wp file wordfence says is modified:

    4338	    * @since 3.1.0
    4339	    * @since 4.1.0 Introduced the <code>$resource_type</code> parameter.
    4345	   return apply_filters( 'get_ancestors', $ancestors, $object_id, $object_type, $resource_type );

    so it doesn’t make any sense to compare 2 different versions, right?
    and throwing a bunch of false positives is pretty anooying…
    how bout first recognizing what version is installed and then compare it to the corresponding core files…

    and is it intended to still show
    © 2011 Wordfence
    on the comparison pages???

    and another thing: where has the much prettier summary page gone (first screenshot https://wordpress.org/plugins/wordfence/screenshots/ )???
    does it have to look THAT ugly as it looks now?
    or is that another pro version feature??

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘comparison with out-of-date core files’ is closed to new replies.