Support » Plugin: WP Job Manager » Company Backoffice Job Listings Pagination Problem

  • Resolved ibiza69


    Hi, today we saw that there is a bug at PAGINATION, at “Company Listings Administration” at their Backoffice.

    I’ll try to explain…

    1. When company has for example 2 or more pages of “Jobs Listings Published” (with none of them marked as filled), when pressing below on pagination 2nd page for example (but happens when pressing any of the pages: 2,3,4,5,…), we get this message at the top: “This position is not filled

    2. When returning back to page 1, the message keeps showing: “This position is not filled“. And keeps showing in any page of job listings administration.

    Same thing happens when “marking a filled position“:

    1. We mark as “job position filled” the second job offer at company listing, everything correct:

    2. But when we press to visit 2nd page of company job listings, the message comes again, but in this case says: “This position has being filled“:

    3. We can return to page 1, go to page 3, 4, 5, etc… and message keeps on showing:

    PAGE 1:
    PAGE 4:

    Could you please fix this of share with us how we could fix it?

    Thank you for your time and dedication.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi again, during this time we thought that maybe could be a translation files problem, so we deleted them (our ones) and downloaded WP Job Manager Translation File for spanish language and faced same problem.

    Well, at pagination when there is “none of the positions marked as filled” at Job Listings Administration, the pagination goes well, with no error.

    The problem now comes with your translation file when marking a “position as filled“, this message shows in every page: “* This aplication has being filled“.

    Hapefully this information helps to fix this, as companies will think that all their positions are being marked as filled, when it´s only one marked as filled.

    Thank you.

    More things…. We have selected that position again as “Not Filled“, the message in color green says “Position Not being filled“.

    BUT when we navigate to page 2-3-4-5,… for example, again shows the message: “* This aplication has being filled“.

    Eeven when returning to page 1 again, the same message appears: “* This aplication has being filled.” and there is no way for taking off that message in any page, and we don´t have any position marked as filled.

    Thanks for any help.

    Plugin Contributor Richard Archambault



    Would you please create a clone of your site as a staging site, where you could more aggressively troubleshoot (toggling things on and off, for example) without affecting your live site? Many hosts provide a staging service, where you can do testing without affecting the live site. You can ask your host about this. If they don’t give you a staging site, you could try WP Staging or Duplicator:

    Once you have your staging copy of the site, on the staging site turn off every plugin except for the WPJM-related plugins made by us at Automattic (turn off those not made by us, if you have any), and switch to a default WordPress theme such as Twenty Sixteen.

    Then, see if you can reproduce the issue, with JUST our WPJm-related plugins and a default theme, and let me know what happens. Also, if you happen to have one of our paid add-ons, you can contact us here for further help:


    Hi Richard and thank you, we shall try to do all this, but will’ll take us time… Hopefully we find the solutuion. We never had this type of problem, for example we have other site with Wp Job Manager Versión 1.31.3 and didn´t face this problem, we where about to update it and finded the problem in other of our sites with last version installed.

    Thanks again Richard.

    Plugin Contributor Richard Archambault


    I’m marking this thread as Resolved as it’s been more than a month since the last reply. If you still need help, please do reply again and mark the thread as Unresolved!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.