Support » Plugin: Companion Auto Update » Companion auto update not working

  • Hello WordPress memebers,
    I have installed this plugin on multiple websites but it is not working.
    Any idea what might cause the problem? I was thinking “All In One WP Security” security might block it but how can I test it?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Might be your webhost. I was using SiteGround and they have an upstream auto updater which overrides Companion Auto Update.

    I generally love SiteGround but their autoupdate service is a very frustrating thing, and getting them to shut it down to use this plugin is like getting Congress to pass a bill.

    Check Companion Auto Update Plugin Settings –> Status tab. Is it a green dot or red dot?

    @a305587
    It’s a green dot. WordPress updates automatically which is normal even without Companion auto update but the Themes, Translations and plugins do not.

    Who is your webhost? Are you on a shared server or VPS?

    hey @a305587
    sorry for my late response.
    I just tested “Easy Updates Manager” plugins and no problems there.
    This plugin does the job.

    Plugin Author Papin Schipper

    (@papin)

    Sad to hear it’s not working for you. Do you still need my help or are you happy with “Easy Updates Manager”?

    Hey @papin
    Would be nice if you could help to fix it.
    The plugins works great normally!

    Plugin Author Papin Schipper

    (@papin)

    Is it working on none of your sites or are only a few broken?

    I myself run “All In One WP Security” on multiple websites as well but I found that this plugin can cause strange issues on some sites while others have no problems with it. Perhaps it could be an issue with permissions, on the WP security >> Filesystem Security >> Permissions dashboard is everything okay?

    Also, @a305587’s question was a good one: Who is your webhost? Some webhosts are a pain in the ass with auto-updating, and sometimes my plugin breaks and sometimes Easy Updates Manager breaks. It’s a strange world we live in…

    You could also try changing the update interval at Companion Auto Update >> Advanced settings, in some cases that worked.

    Hey @papin
    Sorry for the delayed answer.
    Everything is green in the Permissions dashboard and I also asked my webhosting but they aren’t blocking anything.

    However when I reactivated the plugin I got this message:

    Het lijkt er op dat er iets fout ging bij het bijwerken van de database, probeer de plug-in opnieuw te activeren..

    It seems that something went wrong when updating the database, try to activate the plug-in again.

    I also noticed that when I select update Twice a day it switches to Once every 2 hours.
    This also happens when selecting other intervals.

    • This reply was modified 3 weeks, 1 day ago by nesoor.
    nesoor

    (@nesoor)

    Changing the update interval worked but as I said in my previous comment when I select update Twice a day it and save it it switches to Once every 2 hours. This also happens when selecting other intervals.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.