WordPress.org

Support

Support » Plugins and Hacks » Advanced Custom Fields » [Resolved] Compability with Polylang plugin

[Resolved] Compability with Polylang plugin

Viewing 8 replies - 1 through 8 (of 8 total)
  • Could you try with the current development version of Polylang (0.9.6.1)?
    http://downloads.wordpress.org/plugin/polylang.zip

    jussi.r

    @jussir-1

    It works now!

    jussi.r

    @jussir-1

    Nvm It doesn’t work anymore or I didnt’t test very well… Now I can see the custom fields with default language and show all languages only.

    I came back on this and obviously the correction was not complete 🙁
    Could you try with the even newer development version (0.9.6.2)?
    http://downloads.wordpress.org/plugin/polylang.zip

    Sorry, I didn’t see you answered. I can’t try that development version right now but I have version 0.9.8 at the moment and the bug still exists.

    Could you try to add these lines of code in a custom plugin?

    add_filter ('pll_get_post_types', 'do_not_translate_acf');
    function do_not_translate_acf($post_types) {
    	unset ($post_types['acf']);
    	return $post_types;
    }

    In which file I should add those lines?

    Nowhere. This code is now useless in Polylang 1.0.x. Just go the Polylang settings and uncheck the custom post type ‘fields group’ (if it is).

    And you should also uncheck the synchronization for custom fields as it currently breaks Advanced Custom Fields (this should be OK in the future version 1.0.2).

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Compability with Polylang plugin’ is closed to new replies.
Skip to toolbar