Support » Plugins and Hacks » Commit Failed While Uploading My Plugin to Repository

  • Resolved Shrinivas

    (@shrinitech)


    Hi,

    Today my second plugin got approved by WordPress Dev team and I also got SVN repository URL. I checkout out the plugin with Tortoise SVN, copied my plugin files to trunk folder but when I am trying to commit it, I am getting the following error.

    Commit failed (details follow):
    At least one property change failed; repository is unchanged
    Server sent unexpected return value (400 Bad Request) in response to PROPPATCH
    request for ‘/!svn/txn/747084-g5of’

    How to solve this issue? Please help..

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Email plugins at wordpress.org please if this is still happening.

    I ran into this issue with Tortoise SVN this past weekend.

    What worked for me was to do the initial SVN Checkout using https://plugins.svn.wordpress.org/[plugin-name] instead of http://

    After trying that I was able to commit, tag, and make changes to the repository to my heart’s content. 🙂

    I don’t know if this is a bug in Tortoise SVN, or an obscure setting that I haven’t found yet. Either way, using https solved the issue for me.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Commit Failed While Uploading My Plugin to Repository’ is closed to new replies.