WordPress.org

Support

Support » How-To and Troubleshooting » Comments – WP not allowing "don't want to moderate" option?

Comments – WP not allowing "don't want to moderate" option?

  • PiersonDC
    Member

    @piersondc

    Good evening! I run a small, single, privately-hosted site on WP 3.6

    I am using the current version of the Akismet plug-in, but no other comment/spam-related plug-ins or gear. My problem is this: WP has somehow (mistakenly) decided to require me to moderate/approve every comment before it will appear.

    On Settings > Discussion, the “administrator must approve” box and the “comment author must have previously approved …” box are UN-checked. This is how my site has always been, and I have never changed that option. However, about a day ago, my site went from allowing all comments (and then I would have to hack away spam) to forcing me to approve all comments and giving people the “awaiting moderation” message.

    Can anyone explain why this might be? From my options/settings, it very much appears that comments would be permitted by default – but some time over the past 30 hours, WP just decided to require approval. I did get a bunch of spam comments recently (which I manually deleted) – is there any chance that getting a certain # of spam comments automatically engages the “require approval” option regardless of what I’ve selected? Could I avoid this issue by removing Akismet?

    Thank you for taking the time to read, I hope this wasn’t already answered elsewhere (I looked and couldn’t find it). I’d love to get this solved if possible, I definitely want to freely allow comments and don’t mind hacking away spam myself.

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Comments – WP not allowing "don't want to moderate" option?’ is closed to new replies.