Support » Fixing WordPress » Comments wont work on static front page site.

  • I’ve tried all the ways I can find on this forum to get comment boxes to show on a particular page without success.
    I’ve done quick edit and checked allow comments. I’ve checked Comments and Discussions in page editor screen options and allowed comments in the lower discussion dialogue.
    I’ve also tried installing a third party plugin called wpDiscuz but that didn’t show anywhere either.
    The site is at http://conwycameraclub.co.uk and I’m trying to allow comments just on specific pages. Eg About Us.
    Cheers,
    Eugene.
    Possible relevant data follows:
    WP version 4.7.4
    Theme Jolene 1.1.5
    PHP version 5.6.30
    bbPress version 2.5.12-6148
    site url http://conwycameraclub.co.uk
    Active Plugins Name and Version
    – p1 bbP Manage Subscriptions 1.2.0
    – p2 bbP Toolkit 1.0.10
    – p3 bbPress Enable TinyMCE Visual Tab 1.0.1
    – p4 bbPress 2.5.12
    – p5 bbPress2 shortcode whitelist 2.2.1
    – p6 Content Aware Sidebars 3.5.2
    – p7 Duplicate Post 3.2
    – p8 EntryWizard 1.2.27
    – p9 GD bbPress Attachments 2.4
    – p10 Nav Menu Roles 1.8.6
    – p11 PDF Embedder Premium 3.0.1
    – p12 Postman SMTP 1.7.2
    – p13 Remove Widget Titles 1.0
    – p14 Simple Custom CSS 3.3
    – p15 Slideshow 2.3.1
    – p16 TablePress 1.8
    – p17 topic subscribe 1.0
    – p18 User Role Editor 4.32.3
    – p19 User Submitted Posts 20161122
    – p20 W3 Total Cache 0.9.5.4
    – p21 WP User Avatar 2.0.8
    – p22 WPForms Lite 1.3.7.2

Viewing 1 replies (of 1 total)
  • Hi Gene-steve,

    Here are a few more things I’d suggest trying based on passed experiences. Looking at your site if I had to guess I’d say the problem is most likely related to #2: your theme may not support comments.

    1. Make sure you have “Settings > Discussion” configured to “Allow people to post comments on new articles”
    2. Make sure your theme has the comments_template() function configured. If you download your theme to machine and do a basic search within the theme folder for “comments_template” you should find it, most likely inside of a file called single.php. If you don’t find it then you may need to switch your theme.
    3. Make sure your individual posts have not disabled comments for some reason. Check the “Discussion” box below the main post area. If you don’t see it then expand the “Screen Options” area (top right) and make sure “Discussion” is checked. (sounds like you’ve already done this, but mentioning here for anyone else referencing this in the future)
    4. Rare circumstance, but it happened for me at https://www.kevinleary.net/blog/, make sure that your theme isn’t submitting a POST request to a non-https URL. This would result in a blank white screen when a comment is submitted.

    Hopefully this helps, and let me know how it goes.

    -Kevin L.

Viewing 1 replies (of 1 total)
  • The topic ‘Comments wont work on static front page site.’ is closed to new replies.