Support » Plugin: Akismet Anti-Spam » Comments with 1 link put into moderation queue

  • Akismet keeps putting normal comments containing only one hyperlink into the moderation queue. Is that normal? I thought I could change this behaviour using the WordPress settings under Settings -> Discussion (“Hold a comment in the queue if it contains X or more links”). But even when I set it to 4-link threshold, the system keeps marking normal comments as spam when they have even 1 link. Is there anything I can do change this behaviour?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hey there,

    It depends on a lot of things, but Akismet’s result will supersede the discussion setting.

    The first thing to try, so Akismet adapts its behavior, is to mark the messages it flagged as spam as not spam.

    If you continue to see things getting flagged that you’ve marked as not spam, please get in touch with a few example comments and we’ll be happy to look into this further. Please reach out via our contact form and we can take a closer look:
    https://akismet.com/contact

    Thanks for a quick response!

    I always approve the comments that were incorrectly marked as spam. Is that what you mean?

    Also, I’ve just realized iThemes Security plugin has it’s own option to “reduce comment spam”. I disabled it now, could that have had an effect? I’ll keep an eye on it and see if anything changed.

    Plugin Support csonnek

    (@csonnek)

    Happiness Rocketeer 🚀

    I always approve the comments that were incorrectly marked as spam. Is that what you mean?

    If Akismet flags something as spam, it will be put in the Spam tab in your Comments page, not the Pending (or “moderation”) tab. In the Spam tab, you would have to mark something as “Not Spam” to remove it from that section. If it’s being set in the Pending tab (where you “Approve” the comment), that isn’t Akismet doing that.

    Also, I’ve just realized iThemes Security plugin has it’s own option to “reduce comment spam”. I disabled it now, could that have had an effect? I’ll keep an eye on it and see if anything changed.

    It’s possible that was having an effect and putting those comments into Pending. Let us know how it goes!

    Hi again,

    Unfortunately, the iTheme Security main pages do not have much info on what their supposed anti-spam measures are:
    * https://ithemes.com/security/
    * https://wordpress.org/support/plugin/akismet

    The most they mention is enabling Google Captchas, which would probably not affect this.

    If you are having further issues, do get in touch at https://akismet.com/contact with your API key, so we can review the data, and potentially take additinal measures to help you better.

    Cheers,
    Stephane – Akismet Developer.

    I think iThemes Security uses some front-end measure to fight off bots, so that wouldn’t be it.

    What’s your setting for “Comment author must have a previously approved comment”? Is it possible that those comments are simply the first from their respective authors?

    I have that option disabled.

    Plugin Support csonnek

    (@csonnek)

    Happiness Rocketeer 🚀

    @scr00chy:

    Did disabling iThemes Security have any impact? If not, please contact us with your site URL, API key, and the full list of plugins you have installed so we can run further tests:

    https://akismet.com/contact

    Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.