Support » Fixing WordPress » Comments Still Need Approval?

  • In the beginning, I required approval for all comments. Since then I found it to be very cumbersome since there were comment spam filters that did a great job. I then redid the settings for them and allowed all comments and unchecked approval requirement in the settings. I still go into my dashboard and see all the comments in the queue waiting for approval. How do I fix this?

    My blog is located here so that you can see what the problem might be at (included due to entry instructions)

Viewing 6 replies - 1 through 6 (of 6 total)
  • Mikey118


    Add the pluign: Akismet.
    It’s spam filter wordpress plugin that gets rid of scumbags.

    When setting up the plugin you’ll need a key, just use the free verison

    Thanks for the advice though this doesn’t help my problem. The spam thing I have is that very thing, but that isn’t my problem. My problem is all my commenter comments end up in an approval queue and shouldn’t be because it is set to not have to have approval


    I am still having this problem. The settings don’t have that approval is needed in the discussion area, yet I still have to go in an approve comments. Is there no one that can help me work this out?

    If you go to Settings > Discussion
    where it says “Before a comment appears”
    do you have both boxes deselected ?

    If you have the 2nd box selected and none of the authors in the queue have an approved post, they remain there untill they have 1 approved post.

    Thank you for your generous response! seriously

    Yes, I have them both deselected. I’ve tried selecting them and saving and then deselecting them again and saving. It’s just weird.

    Well I think it only counts for new comments and not for existing…

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Comments Still Need Approval?’ is closed to new replies.