WordPress.org

Support

Support » How-To and Troubleshooting » Comments Section on Post not allowing comments, says "No Comments"

Comments Section on Post not allowing comments, says "No Comments"

  • I have created a blog ‘page’ then created two ‘posts’, marked posted to allow for comments on back end, but cannot comment on front end. Click on “no comments” on front end and diverts to a 404 page. All options in Settings>> Discussion checked that need to be.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Please provide a link to yoru site so we can investigate. There are several things which could cause an issue… some are easy to fnd when looking at your source code in the browser

    It’s http://www.altura-construction.com/Wordpress.

    Thanks for taking a look!

    Grrr.. Also the “continue reading” link takes you to a 404 error page
    http://altura-construction.com/Wordpress/builders-blog

    Don’t know what setting I am missing… HELP!

    Yup, should be a simple fix. Your links are broken because they are doubled… take a look at the link for your comments

    http://altura-construction.com/Wordpress/http:/altura-construction.com/Wordpress/home#respond

    So we look at settings->general first to make sure they look right, both should probably be

    http://altura-construction.com/Wordpress/

    Next, what do you have set up in your settings->permalinks settings? Did you just pick one of the standards, or did you try to do something custom?

    You can try setting those back to default first, and test your site. If it’s good, go back to a custom permalink setting

    You were right on about the permalinks. Good grief, it was such an easy fix and it took me HOURS of rooting around to figure it out. THANK YOU!!!

    No problem, I”m glad you got your issue solved!!

    Hi everyone! Maybe I can get some answers here too.
    I have 3 blogs – same theme – ‘Intrepidy’. One I can get comments from readers and the other 2 – ‘comments off’. http://www.hearinggod.mentorsnotebook.com/blog gets comments.
    http://www.totalwholeness.mentorsnotebook.com/blog does NOT. New blog http://www.wholeness.mentorsnotebook.com/blog – only one post and still same problems. New blog has no plugins installed so it isn’t a plugin issue.
    Checked through settings – all OK and comments on as suggested for all three blogs. Tried 5 different themes and all had the same message ‘comments off’ message. People tell me they have sent me a comment but none appears. My test comments do however.
    Don’t know much about php coding as I am rather a newbie too but I DESPERATELY need HELP! I’ve tried to find answers for this for over 3 months from lots of different places….’no joy’ yet!

    Moderator cubecolour

    @numeeja

    ɹoʇɐɹǝpoɯ

    Susanne, this topic appears to have been resolved for alturasite. If setting the permalinks does not work for you, then you have a issue caused by something else so you should start a new topic.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Comments Section on Post not allowing comments, says "No Comments"’ is closed to new replies.
Skip to toolbar