Support » Fixing WordPress » Comments Section not showing

  • Website:

    I cannot seem to make the comments section visible. Whenever some one posts an article I would like other users to be able to leave comments or start their own little discussion on the topic.

    Somehow the comments, whatever I do, don’t seem to appear. So no fields can be filled in by visitors.

    Many thanks in advance,


Viewing 9 replies - 1 through 9 (of 9 total)
  • In the Admin area of your site, click on “Settings” (on the far right). That should bring up the “General Settings” page.

    In the “Membership” row, make sure that the following is checked:
    “Anyone can register” (unless you want to manually add users, say friends and family).

    And that “Users must be registered and logged in to comment” is unchecked. I think that’s the option that’s blocking the comment form in your case.

    By doing what scribblerguy suggests, anyone can add comments. How do you fix Fybro’s problem without unchecking the registered users block?


    Errata for earlier comment: The “Anyone can register” option would be for allowing any random person to get a user-name and password so they don’t have to enter their name, email, website each time they comment on your blog. If you don’t want to have to deal with having registered readers, then you can uncheck that.

    fybro, my suggestion should fix your problem. I see that you’re using the default theme and I checked the settings on my test site. Don’t let poppabear’s post confuse you.

    poppabear: By doing what scribblerguy suggests, anyone can add comments. How do you fix Fybro’s problem without unchecking the registered users block?

    It’s not nice to hijack someone else’s support thread.

    Thanks for the help.
    I think I got a bit confused. I tried your settings and didn’t see any changes until I clicked on a article in the recent posts section.
    Then all of a sudden I saw the comments section.

    Not only me, but also my visitors will still get confused if they don’t immediately see a way to leave some comments.

    Can this be changed by say for instance if I choose a different theme?




    I’m having a similiar problem with comments field box not appearing.

    I host the following website using the dreamplace WP theme. I really like it and don’t want to have to go to change to another theme. However, I don’t seem to be able to get a comment field to appear on any page or post.

    I tried scribblerguy’s suggestion but this seems to make no difference. All the pages have allow comments and pings checked and under general settings I have anyone can register checked and unsers must be regisered and logged in to comment unchecked.

    If anyone could help I’d much appreciate it.

    PS at the top of my posts there is a a link to make comments, after which a comment field appears; see

    However on pages like where I want a comment field, option for leaving a comment without making a post, it seems I cannot make a comment field appear even though on the page set up I’ve checked allow comments and pings.


    I’ve got the same hassle. Very annoying indeed. It shows up for all my older posts. Not sure whats wrong.

    Please help! I’ve tried everything on this thread on my website –

    Same problem. Hope someone will find the solution.

    same problem. seems to be a common one.

    Somebody help! Please! I love my current theme and dont want to change it.. its an integral part of the website.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Comments Section not showing’ is closed to new replies.