Support » Networking WordPress » Comments problem on my pages

  • Hi,

    i am using multisite, and activated jetpack Plugin ( for commenting on my blog posts and pages

    -> when any user comment on my page, an admin not receiving conformation mail to approve

    -> and by deactivating jetpack comments, comments are directly approved and visible on my pages

    Please help me to solve the issue

Viewing 12 replies - 1 through 12 (of 12 total)
  • Did you check if the admin email is correct?
    Is your server a local server or are you using a provider?
    In case of using a local server you might be missing the addon to allow mail sending from it.

    This looks really like a permissions problem.
    Open a terminal window and try this

    chmod -R 777 /applications/xampp/htdocs/[your folder]

    777 permissions are bad, don’t use it unless you absolutely have to!

    Also they have NO bearing at all on email being sent or not.

    Check your PHP error logs for starters, and your mail logs.

    Which admin is not receiving the emails? On multisite it’s the SITE admin, not the network, so if the emails are different, there’ll be that.

    Ipstenu this is a local install, I don’t believe security is something Srikanth should be worried about at this point.

    It’s a bad habit, and like editing core, it’s something that you should only be doing as a last resort when debugging.

    How do you know this is local? He didn’t say so.

    Thanks for your Replay,

    @fiction Edge i am using provider server, admin email id’s are correct

    @ipstenu my network admin is and individual site admin is, so is not receiving commenting conformation mails

    I deduced from the folder name Xampp, but looks I was wrong :p
    When something goes really wrong, I first remove any possible obstacles and one by one I put them back and see witch could cause the problem.

    @ipstenu i changed all multisite admin emails to and on discussion settings selected check box An administrator must always approve the comment now comments are going to admin, but before approving it directly approved and visible on page

    -> comments are displaying without approval of admin but admin receiving tne mail regarding comment post

    I think you were merging topics, @fiction Edge 😉 He didn’t mention xamp!

    Okay, what OTHER plugins are you running? Try turning them ALL off, because if with jetpack OFF the plugins are auto-approved, that implies you have something else wrong, and let’s try to figure out that.


    Fed up with this problem. I am searching for the solution from one month and also not finding solution for this

    Tested by deactivating all my plugins, commenting on my pages,

    On Main site comments are displaying with out admin approval

    On sub sites comment is not at all displaying on my page and no mails are going to admin

    Anyone please suggest me to solve the above issue, Thanks for your Help in advance

    Thanking you,

    Tested by deactivating all my plugins, commenting on my pages,

    Wait … this happens WITHOUT Jetpack active now?

    Make sure you’re using the TwentyThirteen theme, and there aren’t any MU plugins.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Comments problem on my pages’ is closed to new replies.