comments page not showing post (6 posts)

  1. usiddiqi
    Posted 9 years ago #

    My blog: http://umarsiddiqi.com
    Wordpress Version: 2.2

    Ok, I tried searching but didn't find anything related so posting it here. When I click comments link under any post on my blog, it takes me to a comments page that only has comments and no post. I want to change it to show the post followed by comments. Pretty much like you view posts using its permalink, but perhaps jumping directly to comments section. Does that make any sense?

    Any ideas how to achieve that?

  2. moshu
    Posted 9 years ago #

    There is something wrong with your settings. You have this in your source code:
    <a href="http://umarsiddiqi.com/blog/?comments_popup=527" onclick="wpopen(this.href); return false" title="Comment on Cost effective marketing">4 Comments »</a>

    Is your blog set to open the popup comments? (check it in the header)
    Is your theme compatible with WP 2.2?
    What is the code line calling the the comments in the index.php file?

  3. usiddiqi
    Posted 9 years ago #

    moshu, thanks for replying.

    The comments_popup_script() funtion in the header is commented right now. Previously I had setup my blog to open comments in a popup window, but recently I disabled it. Since then comments open this way.

    The code for comments in index page is as follows:

    <div class="post-footer"><?php comments_popup_link('No Comments »', '1 Comment »', '% Comments »','','<span>Comments Off</span>'); ?></div>
    				<?php comments_template(); // Get wp-comments.php template ?>

    I have an idea that something is wrong here, and it really should be calling the post permalink, but I don't know how to change it accordingly.

    Thanks for the help.

  4. moshu
    Posted 9 years ago #

    I don't think you disabled the popup comment.
    The code in your index is fine - leave it like that.

    Do you have a comments.php template file in your theme folder?

    Just out of curiousity: what happens if you switch to the classic or default theme.

  5. usiddiqi
    Posted 9 years ago #

    ok... i commented the php code using <!-- and --> tag instead of //

    Issue resolved. Thanks a million.

  6. idycommunity
    Posted 8 years ago #

    What did you change? I'm having the same problem.

Topic Closed

This topic has been closed to new replies.

About this Topic