Support » Fixing WordPress » Comments on page with comments disabled and no comment box

  • madswedette


    [ Moderator note: moved to Fixing WordPress. ]

    I am using WordPress for a business website. The website is setup with a separate page for each menu item. Nowhere on the pages is there anywhere to enter a comment. I still receive several notifications a day asking for approval of comments for these pages. How can there be spam comments for pages that do not have a place to enter a comment? Some of the comments describe disturbingly offense and depraved websites and include links to the websites. I’ve just been deleting the comments, but it is annoying seeing this stream of garbage. Examining my website pages with the “edit” option, I do not see a way to explicitly disable/enable comments for the pages.

Viewing 3 replies - 1 through 3 (of 3 total)
  • staartmees


    Deleting those comments doesn’t solve the problem. If those comments are not marked by Akismet as spam, you must mark them as spam otherwise Akismet won’t learn a thing.

    Liam Dempsey


    Hi @madswedette,

    You might try the following steps to address that issue:

    (1) Within the WordPress dashboard, navigate to Settings > Discussion.

    (2) Make sure that none of the options under Default article settings are ticked.

    That will disallow comments of any kind on new pages and posts.

    For existing pages and posts, you can turn off comments in bulk.

    (1) Within the WordPress dashboard, navigate to Pages.

    (2) Select the box next to the Title heading.

    (3) From the Bulk Action drop-down menu immediately above the Title heading, select Edit. Then click the Apply button to the right.

    (4) In the dialogue box that appears, select Do Not Allow in the Comments drop-down menu.

    (5) Click the blue Update button.

    To turn off ping-backs on existing pages, for some reason, you’ll need to do those one-by-one (or at least, that’s the only way I know how to do so within the WordPress dashboard.)



    Thank you so much Liam! That’s exactly what I’ve been searching for. Hopefully the gross comments will stop now!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Comments on page with comments disabled and no comment box’ is closed to new replies.