Support » Fixing WordPress » Comments notification not emailed anymore.

  • stainofink

    As suggested, a new thread:
    I’ve been using wordpress for…well quite sometime now. I’m currently using wordpress 1.2.1
    My problem, which just sprung out of nowhere is that when someone posts a comment I no longer get notification emailed to me.
    I’ve tried changing email addresses thinking that perhaps it was my mail server, so I’ve tried my other pop3 accounts and various webmail (gmail, yahoo, hotmail, etc.) but to no avail.
    Curious to know if anyone has or has had this problem and if they know how to correct it.
    Thanks,
    Jessica.

Viewing 15 replies - 1 through 15 (of 35 total)
  • Mark (podz)

    (@podz)

    Support Maven

    Have you contected your host and asked of anything has changed on their side ?
    If it was working, and now it does not, then someone has introduced a change somewhere.

    Anonymous

    Nothing has been changed on the server side that’s why I’m so perplexed

    deb5376

    (@deb5376)

    Jessica, the same thing has happened to me. I haven’t made any changes and neither has my host. The notification problem just sprung up out of the blue.
    I hope you find out what’s caused it and hope someone here can help because it’s obviously not an isolated case.
    Will be checking back…
    Thanks.

    the same thing has happened with me too, i think this happens only in the 1.21 version…. it was working fine till the last version.

    I still haven’t been able to fix it, anyone else find anything new?
    Thanks.
    Jessica

    Moderator James Huff

    (@macmanx)

    Halfelf Minion 🚀

    Out of the off chance that it’s just a weird glitch, go to Options/General, change the email address to anything, hit save, then change it back to whatever you prefer, and hit save again. I’ve never had this problem, so I’m not sure how to fix it. But I am running v1.2.1.

    I’ve tried before but just by chance tried again because of your suggestion, but no luck. Thanks though.
    Jessica

    Just trying to boost this discussion back up, wondering if anybody has figured out this problem yet? It’s been months and I still haven’t figured out the culprit.

    I’m having the same problem on 2 wp sites. One running 1.3-alpha-4 and the other 1.5-beta-1 2005-01-15 but the notifications haven’t worked since 1.2.

    Just wanted to bump this thread. #

    *sigh* I’m sorry. Nevermind for me.

    I had the same problem on my new installation (1.2.2). After a quick trace in the code I could find nothing wrong there. Then I tried mailing using the “mail” command on a console.
    ( type “mail you@email.address” <enter> “some text” and ctrl-d ctrl-d. )

    This also didn’t work indicating that wordpress was not the problem. It turned out to be a rights issue on the dir where the mail command drops the mail.

    Hope this can help somebody.

    Thanks for the input Martijn. Your post actually headed me into the right direction. I logged onto my server via FTP to check the permissions for all my files (by checking the properties for the directories). It turns out that my dirs have all the wrong permissions set. Which now has me in a new problem…

    I chmod the files and folders to the correct permissions only my FTP client [leapftp] spit back and error: “500 Unknown Command”. Now I’m doubly perplexed.

    Jessica

    Guess it’s time to figure this problem out now too.

    Same problem over here. Version 1.5. I tested the mail command & it works fine on the server.

    I dug out the functions.php file in the wp_includes directory which contains the wp_mail function. Flagged around the
    return @mail($to, $subject, $message, $headers, $more);
    line, which showed it is running that command.

    Took the @ off the front of the function & it still returned no errors. However the function returns a blank value (ie. false) so the php mail command isn’t working.

    So I replaced the command with mail('**my email address**', 'Hello', 'This is atest'); and it worked! So there seems to be a problem in the arguments being sent to the mail function.

    Still looking…

    OK, I’ve found that if I remove the $more parameter from the
    return @mail($to, $subject, $message, $headers, $more);
    function it works.

    Funny thing is that the $more variable is empty, no value at all.

    Very weird.

Viewing 15 replies - 1 through 15 (of 35 total)
  • The topic ‘Comments notification not emailed anymore.’ is closed to new replies.