Support » Fixing WordPress » Comments not working, goes to blank page.

  • This is a strange problem and just started occuring not long ago for no apparent reason, my comments used to work but one day just stopped!

    When anyone tries to submit a comment in either FF or IE it just goes to a blank wp-comments.php page

    I have no plugins installed and does not work in the default theme either. I upgraded to 1.5.1 and this did not fix it either.

    The address of my wp install is http://randomo.ocel.co.uk if anyone wants to test it out for themselves.

    I appreciate any help anyone has to offer.
    Thanks.
    Alex.

Viewing 10 replies - 31 through 40 (of 40 total)
  • I just started having a similar issue. After someone leaves a comment, they are sent to marysorens.com/wordpress/, which is actually a directory, since the index file is in a different location.

    It had nothing to do with plugins, tried disabling. It appears that those using security software like ZoneAlarm will have to go in and add sites individually where they would like to enable private headers and cookies. That fixed the problem on my site. Of course, I had to enable them at marysorens.com AND at http://www.marysorens.com.

    This is very frustrating, because most of my users would not know how to do this. So they will continue to see a directory after they enter a comment. There must be some way to fix this with code?

    I had the same problems (WP 2.0.2) and just changed the PERMALINKS back to default (I had date and name based before) and now everything works fine 🙂

    I had the same problem. I just shutdown the firewall and the problem was gone… Is there a way to make WP not to use HTTP_REFERER?

    Matej

    I had this problem too, updated to 2.0.4 and had the Mallow theme and comments weren’t working. If you are having the same problem I suggest you use darniaq’s solution!

    Ok I had a similar problem in that when people tried to add a comment it appeared to change pages but then went back to the page they were originally on without any form to fill in. After some trial and error within the options part of the admin pages I found that setting the permalink structure back to default allowed visitors to leave comments again.

    I have been using the WP default template for our comments.php page and no matter what I alter NOTHING has any effect on it! Could someone please take a look and let me know what they think is wrong?

    http://www.fauxialite.com

    Has anyone suggested bumping up the memory_limit value in php.ini from 8M to 16M or 32M? That always fixes it for me.

    That only works if your host is willing to make changes to your account to incorporate that. Many hosts aren’t.

    The blank comment page happened when I installed WWW Redirect plugin and forgot to update the URI in General Options.

    From http://trac.wordpress.org/ticket/1181

    I found IT. When you have a redirect on your server like me (http://weblog.unitedstatesofpeter.com redirects the browser to http://unitedstatesofpeter.com/weblog ) and you have set in the options, the Blog address (URI) as the first mentioned URI then 2 things dont work: you cannot promote users, even if you do all the referrer stuff, and your comments go to a blank page. It is a bug I think because my users should be able to get linked all the time to weblog.uni…. . But OK. For me it works now!

    I’m the latest victim. I’ve tried all the solutions proposed above (disabling Akismet, copying the comments.php file from classic to my theme and changing the URI setting) and nothing is working. Though I believe this started after a sympathetic geek did some monkeying with my URI setting and my .htaccess file.

    here’s what the .htaccess file looks like now:

    Redirect 301 /wordpress http://www.killingbatteries.com
    Redirect 301 /travelogue http://www.leifpettersen.com

    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^killingbatteries\.com
    RewriteRule (.*) http://www.killingbatteries.com/$1 [R=301,L]

    Any suggestions?

Viewing 10 replies - 31 through 40 (of 40 total)
  • The topic ‘Comments not working, goes to blank page.’ is closed to new replies.