Support » Fixing WordPress » Comments not working… can be entered but submission fails

  • I have checked the forums, but have not found a solution to this problem. Any assistance or insight would be greatly appreciated.

    After a brief hiatus, I have my blog back up and running. I am using the latest version of WordPress – 2.7.1

    It is possible to follow the link for comments, which brings you to the individual post page, with a comment box at the bottom. When you hit submit, the following error message appears:

    Not Found

    The requested URL /home/david/www/^$ was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    I have a feeling that this may have something to do with the .htaccess file – but not really sure.

    What I can tell you is that /home/david/www refers to my root home on the server (who is graciously provided by a close friend, Ryan Shea, under the monikor of “Muppethouse”). I am not sure what the “^” symbol is, and the IP address may be associated with the server, maybe not. It leads to a DLink login page.

    I have searched through all the menus, and cannot find anything that would be causing this.

    Other details:
    I am using Askimet (incredible plugin)
    I am testing from Belgium, and the server is hosted in Maclean, VA, USA
    I am using a modified version of the “Generic Design” template created by Mike Joes (Great template, thanks Mike!)
    I have tested against the default template and a couple of others – the template does not seem to be the issue, it occurs in each of them.
    I am hosting the main page at the root level, with the rest of the files hosted in the wordpress directory, followed all instructions, and this seems to be working (aside from the comments)
    I am a Libra, and enjoy long walks on the beach and small dinner parties with lots of great food and wine… and great company

    Any insight would be greatly appreciated. You can see the blog here:

    Many thanks for any assistance!


Viewing 4 replies - 1 through 4 (of 4 total)
  • Hello – I wanted to bump this back up… I still have not been able to resolve. If anyone has any ideas I would greatly appreciate it. Thanks!


    1.) Comments not able to send the input if not logged in. Fails in an error message.(theme specific, no useful info)

    2.) Forgot password page fails after hitting submit. Results in a white page.

    3.) No welcome e-mail on creation with the login info either.

    WP 2.7.1 downloaded recently, hosted on a dedicated server. Webhosts support staff cant see the problem. Ajax involved. On localhost, everything works perfectly though.

    There was a similar issue 3 years before with wpmu:

    The code in the thread resulted associated to comments in the following: – same appeared as above, same error message, but after refreshing the page, the comment was there.



    seems everywhere where the modrewrite should work, it doesnt, its trying to post to a table which doesnt exist, or doesnt get any answer back from.

    Check in your Settings, Permalinks and under Common settings make sure you have Default selected. That worked for me…


Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Comments not working… can be entered but submission fails’ is closed to new replies.