WordPress.org

Support

Support » Plugins and Hacks » Comments not working

Comments not working

Viewing 15 replies - 1 through 15 (of 17 total)
  • Moderator James Huff

    @macmanx

    Go to Options/General and uncheck “Users must be registered and logged in to comment”.

    It is unchecked.

    To clarify, yes, I had already unchecked it. It still does not appear to be working – see the site for example.

    I also tried re-upgrading WordPress (downloaded the 1.5 zip, uploaded all files, copied my config.php, regenerated my .htaccess) and still no go.

    Again, “Users must be registered and logged in to comment” is unchecked.

    Moderator James Huff

    @macmanx

    Run /wp-admin/upgrade.php .

    Moderator James Huff

    @macmanx

    Elliot, on your blog you mention deleting the section of code which controls whether or not registered users can post. I highly suggest that you replace your copy of /wp-content/themes/default/comments.php with a fresh copy from a new WordPress download.

    I have replaced it with the original version. I am using a fresh copy from a new WordPress download (wordpress-2.5-strayhorn.zip).

    Deleting the section of code allowed the name and email boxes to show up, however, they did not work. Filling them out had no effect (it posted as Anonymous).

    To clarify, the blog is now using the default WordPress install with the original /wp-content/themes/default/comments.php.

    I realized my code edit, although it made the name, email, and website boxes appear, did not cause them to actually function. The blog is now reverted back and the WordPress files are the original ones. The only change from a default install is that –

    1) It is an upgrade, so the database is an old one; Yes, the upgrade.php file has been run.

    2) I am using “pretty” permalinks with a custom .htaccess file.

    That is all..

    Moderator James Huff

    @macmanx

    Out of curiosity, will comments work if you enable the Classic theme?

    Good idea. Unfortunately, it’s the same result:

    Logged in as . Logout »

    I’ll leave it on Classic for now, so you can see.

    Note that it’s the same with the default (new) theme.

    Moderator James Huff

    @macmanx

    0_0 Wow. I’m out of ideas, sorry. Anyone else?

    Looking at the code, I think a value must be getting into $user_ID somehow. Where is this variable initialized?

    Where is get_currentuserinfo() ?

    I’m facing the same problem; I’m pretty sure that something has failed during the database conversion process for 1.2.1/1.2.2 users.

    In short, I’ve had to simply turn comments off because people kept replying into the db_blackhole 🙂

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Comments not working’ is closed to new replies.
Skip to toolbar