WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Comments not showing up – not theme related

[Resolved] Comments not showing up – not theme related

  • I have a post for which there are 4 comments that are not showing up, and I believe it has something to do with the fact that it was published before it was supposed to be, then put back to “draft” status, then published again on the correct date, and then that publish date was changed so that a link to it from another site would not be broken – messy, I know. Comments are working fine on all other published posts so that’s why I’m sure it’s not theme-related but rather due to the messy handling of this particular post, but I still need to find a way to fix this post so that the comments that were left will show.

    I’ve checked the database (wp_comments table) and the 4 comments are there and do show the correct Post ID, show approved status of 1, and comments are allowed on this post.

    Is there anything I can try short of deleting them and re-entering them myself?

Viewing 9 replies - 1 through 9 (of 9 total)
  • esmi

    @esmi

    Forum Moderator

    Are the dates on these 4 comments before the final publication date on the post, by any chance?

    Hi esmi – thanks for your reply…..

    The first two comments left were initially dated before final publication, but I’ve since gone in to my database via phpMyAdmin and changed the dates on those so that they are after, hoping that this change would help, but unfortunately it has not – so now even though all comments are post-final-publication-date, they still do not show up. I even made a new (5th) comment on that post to see if it would force them to display – no luck. I also verified that the comment status is still set to open.

    Oddly, I have a section in my sidebar for Most Recent Comments (a tab) and the links to the comments show up there, but they still don’t display down below the post where they should be so that you can actually see them.

    I’m stumped……

    esmi

    @esmi

    Forum Moderator

    Did the 5th (new) comment appear on the site in the correct place?

    AHA! I figured it out – posting this just in case anyone else has this same issue (with the same cause of course)…..

    This is a simple case of “me being a dummy” 🙂 – I had a section in the theme file to show related posts (related by category) and was doing a new query that was causing the Loop to forget the post ID of the current post that was being displayed – this was occurring BEFORE the call to comments_template() so it did not know which post ID’s comments to display…..

    SO I moved that section to AFTER the comments section – and now it works – it’s not ideal, since I wanted to display a short list of related (by category) posts BEFORE the comments, but until I can find a better way, at least this works…..

    Thanks esmi for replying…..I appreciate your time….

    I have two wordpress sites with two different themes. One shows comments just fine and the other does not display comments. Can you point me in the right direction to resolve this problem?

    Thanks,

    Jim

    your theme probably doesn’t have comments active in it.

    Look at the index.php file for the theme with comments, compare it to the one without comments.
    (you could also look in page.php, or single.php)

    look for something referencing comments_template or comments_popup

    mine looks like:
    <?php comments_popup_link('ADD COMMENTS', '1 COMMENT', '% COMMENTS'); ?>

    if thats the case, copy the code over

    Thanks. I will check on this. My coding skills are limited but I do need to know how to do this stuff.

    My main index is a static page that I set up for the site that is not displaying comments/responses. I checked the page.php and the code is below. Hoe does it look? Also the dashboard does show comments?

    Thanks for your help.

    </div>
    </div>
    <div id=”postmetadata”>
    <div class=”alignleft”>#comments”>Comments-<?php comments_popup_link(__(‘No responses yet’), __(‘One response so far’), __(‘% responses so far’)); ?></div>
    </div>
    </div>

    thank

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Comments not showing up – not theme related’ is closed to new replies.