WordPress.org

Forums

Comments Not Showing Up in Version 2.01 (9 posts)

  1. lisar915
    Member
    Posted 9 years ago #

    Hey folks,
    I just upgraded to version 2.01. But today, I just noticed that none of the comments are actually showing up on my blog even though I am receiving them via email. Would anyone know why that is?

    Thanks.

  2. Skyzyx
    Member
    Posted 9 years ago #

    I have a similar problem where people who try to post comments in 2.0.1 get the "White Screen of Death" (aka absolutely nothing). Didn't have this problem under 2.0.

  3. spencerp
    Member
    Posted 9 years ago #

    Got a link? Maybe someone can see what's going on and help ya better.. =)

    spencerp

  4. gnukerman
    Member
    Posted 9 years ago #

    After upgrading 2.0 to 2.0.1 I am now getting the following error and none of my posts and/or comments show up on the main page or in the admin | manage screens.

    Running Plesk 7.5.4 | FC2 | mySQL 2.0.17 | php 4.4.1 all patched.
    .....
    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND comment_approved = '1'' at line 1]
    SELECT COUNT(comment_ID) FROM wp_comments WHERE comment_post_ID = AND comment_approved = '1';

  5. Skyzyx
    Member
    Posted 9 years ago #

    http://simplepie.org/blog/
    http://simplepie.org/ideas/
    http://simplepie.org/docs/reference/

    Three separate WordPress installations, all working fine under 2.0, all have broken comments in 2.0.1.

    As a note, I have Dreamhost, and used their one-click-upgrade to upgrade all of these to 2.0.1.

  6. gnc1
    Member
    Posted 9 years ago #

    I upgraded to 2.0.1. My posts still show "allow comments" but comments no longer show on posts.

  7. muskie
    Member
    Posted 9 years ago #

    Damn. I too am having problems involving comments and apparently the parsing of my comments.php file. When you try to view an individual posting which was borked under WordPress 2.0 you get the following error:

    Parse error: parse error, unexpected T_ENDIF in /home/muskie/domains/muschamp.ca/public_html/blog/wp-content/themes/muschampTabs/comments.php on line 78

    One side effect of this, is it messes up my .CSS I'm not sure style.css is getting loaded totally in Opear (my browser of choice) I get some formatting because my WordPress Theme is an extension of my main website so all the CSS inherrited from the main site is applied and it is contained in a file called muschampTabs.css I think. On my front page again at the very bottom of the page I get this error now:

    Dave. [post_title] => Oh yeah, I ate frog [post_category] => 0 [post_excerpt] => [post_status] => publish [comment_status] => open [ping_status] => open [post_password] => [post_name] => oh-yeah-i-ate-frog [to_ping] => [pinged] => [post_modified] => 2006-02-01 08:14:48 [post_modified_gmt] => 2006-02-01 13:14:48 [post_content_filtered] => [post_parent] => 0 [guid] => http://blog.muschamp.ca/2006/02/06/oh-yeah-i-ate-frog/ [menu_order] => 0 [post_type] => [post_mime_type] => [comment_count] => 0 ) ) [queried_object] => [queried_object_id] => 0 )
    SERVER

    Array
    (
    [DOCUMENT_ROOT] => /home/muskie/domains/muschamp.ca/public_html/blog
    [HTTP_ACCEPT] => text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
    [HTTP_ACCEPT_CHARSET] => ISO-8859-1,utf-8;q=0.7,*;q=0.7
    [HTTP_ACCEPT_ENCODING] => gzip,deflate
    [HTTP_ACCEPT_LANGUAGE] => en-us,en;q=0.8,ja;q=0.5,zh-cn;q=0.3
    [HTTP_CONNECTION] => keep-alive
    [HTTP_COOKIE] => __utmz=217375882.1139048333.13.12.utmccn=(referral)|utmcsr=blog.muschamp.ca|utmcct=/|utmcmd=referral; MintPane1=1; MintAuth=3f56b079efd36da4e63ff364e0da8027; MintPane4=0; MintPane3=1; __utma=217375882.1392118245.1134811149.1138963284.1139048333.13; MintPane2=0; MintUnique=1; MintIgnore=true; wordpresspass_2f3cd5c3739319dd07d94510f13f9398=43ecaa3b277255605e18052510ad16d9; dbx-postmeta=grabit=3+,4+,5+,0-,1-,2-,6-&advancedstuff=0-,1-,2-; wordpressuser_2f3cd5c3739319dd07d94510f13f9398=admin; comment_author_url_2f3cd5c3739319dd07d94510f13f9398=http%3A%2F%2Fwww.muschamp.ca; comment_author_email_2f3cd5c3739319dd07d94510f13f9398=andrew%40muschamp.ca; __utmz=143861734.1134802966.1.1.utmccn=(direct)|utmcsr=(direct)|utmcmd=(none); __utma=143861734.373055463.1134802966.1138529892.1138533545.78; comment_author_2f3cd5c3739319dd07d94510f13f9398=Muskie
    [HTTP_HOST] => blog.muschamp.ca
    [HTTP_IF_MODIFIED_SINCE] => Sat, 11 Feb 2006 07:33:28 GMT
    [HTTP_KEEP_ALIVE] => 300
    [HTTP_REFERER] => http://blog.muschamp.ca/2005/10/31/baidu-chinas-search-engine/
    [HTTP_USER_AGENT] => Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
    [PATH] => /sbin:/usr/sbin:/bin:/usr/bin:/usr/X11R6/bin
    [REDIRECT_STATUS] => 200
    [REDIRECT_URL] => /
    [REMOTE_ADDR] => 61.149.142.124
    [REMOTE_PORT] => 19913
    [SCRIPT_FILENAME] => /home/muskie/domains/muschamp.ca/public_html/blog/index.php
    [SERVER_ADDR] => 209.51.150.21
    [SERVER_ADMIN] => webmaster@muschamp.ca
    [SERVER_NAME] => blog.muschamp.ca
    [SERVER_PORT] => 80
    [SERVER_SIGNATURE] =>
    Apache/1.3.33 Server at blog.muschamp.ca Port 80

    [SERVER_SOFTWARE] => Apache/1.3.33 (Unix) mod_ssl/2.8.22 OpenSSL/0.9.7a PHP/4.3.10 mod_perl/1.29 FrontPage/5.0.2.2510
    [GATEWAY_INTERFACE] => CGI/1.1
    [SERVER_PROTOCOL] => HTTP/1.1
    [REQUEST_METHOD] => GET
    [QUERY_STRING] =>
    [REQUEST_URI] => /
    [SCRIPT_NAME] => /index.php
    [PATH_TRANSLATED] => /home/muskie/domains/muschamp.ca/public_html/blog/index.php
    [PHP_SELF] => /index.php
    [argv] => Array
    (
    )

    [argc] => 0
    )

    REQUEST

    Array
    (
    [__utmz] => 143861734.1134802966.1.1.utmccn=(direct)|utmcsr=(direct)|utmcmd=(none)
    [MintPane1] => 1
    [MintAuth] => 3f56b079efd36da4e63ff364e0da8027
    [MintPane4] => 0
    [MintPane3] => 1
    [__utma] => 143861734.373055463.1134802966.1138529892.1138533545.78
    [MintPane2] => 0
    [MintUnique] => 1
    [MintIgnore] => true
    [wordpresspass_2f3cd5c3739319dd07d94510f13f9398] => 43ecaa3b277255605e18052510ad16d9
    [dbx-postmeta] => grabit=3 ,4 ,5 ,0-,1-,2-,6-&advancedstuff=0-,1-,2-
    [wordpressuser_2f3cd5c3739319dd07d94510f13f9398] => admin
    [comment_author_url_2f3cd5c3739319dd07d94510f13f9398] => http://www.muschamp.ca
    [comment_author_email_2f3cd5c3739319dd07d94510f13f9398] => andrew@muschamp.ca
    [comment_author_2f3cd5c3739319dd07d94510f13f9398] => Muskie
    )

    -->

    It used to have less crap, I would hyptothesize that my friend Dave tried to leave a comment about me eating frog. I never got an email confirming this comment. I'm using 2.0.1 and Ir ecently started using Spam Karma 2.0 I can totally live without it, but if I disable all my plugins my theme starts to look ugly in the sidebar. Note on my main page I get a white background which means that style.css loaded more completely.

    Any suggestions. I have limited time, limited patience, and limited internet access being on my last six days in China. I just want to update my blog so I can take over the world or at least the search engine results. when I get back to Canada I'll fix this, but the errors are getting bigger and uglier so I thought I'd post something.

    http://blog.muschamp.ca/

    Try any single post you want, the older the better I guess to see the first error.

    Muskie

  8. aviaviavi111
    Member
    Posted 9 years ago #

    showing gr8.

    tnx
    avi
    http://www.listen2myradio.com/

  9. jennatar
    Member
    Posted 8 years ago #

    Like Skyzyx I get white screen of death--no nothing, not even a friendly error.

Topic Closed

This topic has been closed to new replies.

About this Topic