WordPress.org

Support

Support » How-To and Troubleshooting » Comments not showing

Comments not showing

  • Hi,
    for some reason, comments on my site dont show up, even though wordpress registers that they are there. The number of comments updates, and I can read the comments from the wordpress dashboard, but it still shows no comments on the actual page.
    Does anyone know how to fix this? I have spent tons of time browsing the forum trying to find a solution, with no luck so far…

Viewing 11 replies - 1 through 11 (of 11 total)
  • Tara

    @t-p

    Volunteer Moderator

    Do they show up if you temporarily switch to the WP default Twenty Twelve theme?

    That is one of the few things I havent tried yet. I am using a custom theme, and am a little worried that i will have to reconfigure the whole site if i do this. Are you sure this won’t mess everything up? Sorry if this is a dumb question, I’m still a little new to wordpress.

    esmi

    @esmi

    Forum Moderator

    Are you sure this won’t mess everything up?

    All changes should only be temporary.

    They do show up when I do that. Should i just try taking comments.php from that theme and putting it in mine?

    esmi

    @esmi

    Forum Moderator

    No – you cannot do that. Where did you download your old theme from?

    It’s a custom built theme, though I wasn’t the one who built it.

    esmi

    @esmi

    Forum Moderator

    Then you will either need to go back to the person who developed the theme or you will need to start work on some theme development yourself. I’d suggest starting with Theme Development.

    Yeah, so the original theme didn’t have comments, I’ve been trying to add them and run into this problem. I just took comments.php from the WordPress classical theme and put it in my theme. It works, except for the comments not actually showing…

    Tara

    @t-p

    Volunteer Moderator

    Does your custom theme have single.php?
    Do you have this line in single.php?
    <?php comments_template(); ?>
    If you don’t, try adding it after The Loop.

    It shows the comment interface and all, I’m using <?php get_template_part('comments'); ?> though. It says “1 Comment” as the title, and right underneath it says “No Comments”, then it has the submit a comment interface. Its having trouble printing the comments or something.

    Tara

    @t-p

    Volunteer Moderator

    I suggest you follow esmi’s suggestion.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Comments not showing’ is closed to new replies.