Support » Fixing WordPress » Comments not recognizing WP accounts

  • Hi and thanks in advance. Can’t find any record of anyone else with this weird issue:

    Recently upgraded to PHP 7.4 and I’m running into an error. Comments are working on my blog as normal, UNLESS I (or my co-editor) tries to comment while logged in with a WordPress account. If we’re logged in, we get :

    ERROR: please fill the required fields (name, email).

    If I turn off require name/email in comment settings, the comment goes through, but is recorded as “anonymous” even though the front end recognizes me (shows avatar, etc).

    If I logout of WordPress and try commenting, that works. Then, if I log back in, it SOMETIMES works but sometimes I get:

    unused
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, email@example.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    Tried disabling all plug-ins but that didn’t help.

    Clearly, not a crisis. But all the same, would love to fix this problem so we can respond to our dwindling number of readers.

    Any advice? I’m able to follow instructions, but not an engineer…

    • This topic was modified 2 years, 1 month ago by Marius L. J..
    • This topic was modified 2 years, 1 month ago by Marius L. J.. Reason: Removed email address

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • If you have not already used the health check plugin https://wordpress.org/plugins/health-check/ to confirm that a plugin or your theme are not causing this issue.

    Once you have done that it the problem persists let us know and we will try to help as best we can.

    Thread Starter xzackly

    (@xzackly)

    Thanks Davood.

    I installed WP HealthCheck and it flagged that my site didn’t have https set up, so I ordered a cert through my host, and that’s active now. I also flushed the object cache. I didn’t get any other errors.

    Ran another comment test and there’s been no change.

    I appreciate any other assistance you can provide! Is there some way to reset the approved commenter list? I’m wondering if the db got corrupted or in some other way disconnected from WP so those logins aren’t registering…?

    Did you actually activate debug mode in the plugin. It can be confusing at first to use the health check plugin. This is a problem that is likely being caused by a plugin or your theme. Any time I’ve had similar problems during my ten plus years of working with wordpress it has been related to a plugin, and once it was related to a bug in my theme.

    Thread Starter xzackly

    (@xzackly)

    Ah. I didn’t see that option. I’d try it now, but I appear to be locked out of wp-admin. I’m guessing it’s the new cert not quite settled in yet? Or hopefull that’s it. I keep logging in and it punts me back to the login page.

    Will report back after I regain access…

    Thread Starter xzackly

    (@xzackly)

    Okay. Getting there. My panel was adding a WWW and WP was removing it so I was caught in a loop. Now I’m back in and I’ve installed the RIGHT Health Check plug-in this time.

    Here’s what I’m seeing:

    The REST API encountered an error Performance
    The REST API is one way WordPress, and other applications, communicate with the server. One example is the block editor screen, which relies on this to display, and save, your posts and pages.

    The REST API request failed due to an error.
    Error: [] cURL error 28: Operation timed out after 10001 milliseconds with 0 bytes received

    Your site could not complete a loopback request Performance
    Loopback requests are used to run scheduled events, and are also used by the built-in editors for themes and plugins to verify code stability.

    The loopback request to your site failed, this means features relying on them are not currently working as expected.
    Error encountered: (0) cURL error 28: Operation timed out after 10000 milliseconds with 0 bytes received

    Unfortunately, I have never seen this error from the health check plugin and I am not sure what to suggest. You can manually disable all plugins and switch to a default theme and test that way if you would like to do that. If it commenting works correctly with the default theme and no plugins then reactivate the theme and test again… after reactivating the theme reactivate each plugins one by one until you find the culprit. That is the best I can offer. Someone else who volunteers here in the community might be able to offer some other advice.

    Hope this helps.

    Actually, I just realized something. I think you are using the built in health check feature to see that error… not the plugin I suggested.

    Please make sure you are using the plugin I suggested, it will do what I described in my last post but only for the logged in user not for all users. the only part it wont do is reactivate plugins one-by-one. You will need to do that. Chances are you have a plugin that is causing the issue you are experiencing you need to figure out which plugin it is.

    https://wordpress.org/plugins/health-check/
    This is the plugin I suggested earlier… it is not the same as the health report that is built into wordpress.

    Thread Starter xzackly

    (@xzackly)

    Thanks again Davood,

    I’m using that plug-in, and it didn’t throw any plug-in related errors. I haven’t gotten into debug mode, as switching to https has broken all my image links and I’m fighting that battle first (with support from my host). I did, earlier, disable all plug-ins and that didn’t fix the issue, but it’s worth trying again through HealthCheck.

    I’m beginning to suspect it’s something to do with Jetpack; a muddled or conflicting account issue?

    We’ll see if Dreamhost can help me un-bork everything and get my site working right. They’ve been super helpful and right now I’m just trying to stay out of their way.

    But I appreciate you continuing to keep an eye on me, and trying to help me, even though clearly I’m just making things worse…

    Hope you’re doing well.
    z

    Yes, fixing the SSL issue is definitely something that should be done first. Sorry, I misunderstood that you were still fixing that. Until that is fixed even disabling all plugins manually probably would not fix the issue.

    I definitely don’t mind keeping an eye on this thread to be sure you find a solution. Feel free to post updates as you have them.

    Thread Starter xzackly

    (@xzackly)

    Hi Davood,

    Closing the loop here. There was an issue with my htaccess file, that the kind folks at Dreamhost fixed for me. That solved all the issues—-including apparently, the issues my site was having communicating with WP to authenticate users.

    The CSA said:

    I then turned my attention to getting HTTPS to work consistently and I
    think I was finally able to do that once I updated your .htaccess
    anti-hotlink code to use HTTPS.

    I’m a little confused as how an issue that predated the switch to https could be fixed in this way, but also: just glad it’s working. Tested it a few times and the issue is no longer occurring.

    I doubt anyone else will run into this same issue, but just in case: that was the fix.

    Thanks again for your assistance.
    Zack

    Glad they were able to fix it for you and everything is working now. Thanks for sharing the fix so others know what it was.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Comments not recognizing WP accounts’ is closed to new replies.