Support » Plugin: Blogger Importer » comments not importing

  • I have been able to import all the blog posts but not the comments. I have restarted import many times already and it seems that just the comments are not importing. The very first time I did the import, 26k of the 67k comments imported but I didn’t have the chance to finish the import and stopped in the middle. I resumed the import last week and it loaded up to 29k comments. Now the rest will not import at all. It will sometimes go straight to “Load Authors” and completely bypass the comments.

    I’ve tried to create an account on and import from as WordPress instead but nothing is loading and I’m not sure if it is because the XML file is too large.

    Please help!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Workshopshed


    Do you get any messages in your error log ?
    Is there any pattern to which are not loaded, is it all the comments from a selection of posts or missing comments scattered across lots of different posts?

    There were no error messages that I noticed.

    The 29k that did load were all in order from older to newer posts. Now, zero comments (not even duplicates) will import. It will import all posts and then completely stop at the comments.

    Plugin Author Workshopshed


    How big has your database got to?
    When it runs it’s going to check each of the comments to see if it already exists so I can see it slowing down with such a large number of comments.

    You could potentially improve this by changing one of the functions in comment-entry.php to be a lot simpler.

    function exists()
                return ($this->get_comment_by_oldID($this->self));

    There is a small risk that you might end up with duplications particualarly if you’ve changed any of the comment meta entries.

    I’ve tried this on my setup and it seems ok

    Plugin Author Workshopshed


    Another quick question. How long does it take to process your import?

    Hello, I have the same problem as mention above.

    I’ve got 224 post and 11,783 comment to import. So far the post has done imported but the comment stuck at 478.

    The process to import 224 post and 478 comment was pretty quick , but it got stuck in the middle for hours.

    I tried to import to

    In WP importer i changed few values, because at first it just import 125 posts and no comments.

    const MAX_RESULTS = 20000; // How many records per GData query (int)
    const MAX_EXECUTION_TIME = 200; // How many seconds to let the script run (int)
    const STATUS_INTERVAL = 3; // How many seconds between status bar updates (int)
    const IMPORT_IMG = true; // Should we import the images (boolean)
    const REMOTE_TIMEOUT = 100; // How many seconds to wait until google responds (int)
    const LARGE_IMAGE_SIZE = ‘1024’; // The size of large images downloaded (string)
    const POST_PINGBACK = 0; // Turn off the post pingback, set to 1 to re-enabled(bool)
    //N.B. Not all images will be this large and not all will be able to be remapped.

    Plugin Author Workshopshed


    Sutiknyo, I pointed my importer at your comment feed and noticed something interesting. The comment feed includes comments for posts in 2007 that appear to no longer exist. Those comments contained different data to the real comments and could cause an error to occur.
    I’ve coded the comment processing code a little more defensivly so it should be able to handle that now.
    This plus above performance change added to the latest dev version at

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘comments not importing’ is closed to new replies.