Comments not displaying in WordPress 3.5 (12 posts)

  1. patocka
    Posted 3 years ago #

    Here's my stack:

    WordPress 3.5, Thesis 1.8, Disqus 2.74, also using Jetpack.

    For some reason comments are disabled for my posts. Steps taken to troubleshoot:

    1. Checked Settings > Discussion

    Confirmed default article settings:

    [ ]Attempt to notify any blogs linked to from the article
    [x]Allow link notifications from other blogs (pingbacks and trackbacks)
    [x]Allow people to post comments on new articles

    2. Attempted toggling Posts quick edit feature [x] allow comments. That didn't work.

    3. Checked Disqus settings. Comments enabled for all current and future blog posts.

    4. Checked Jetpack. Confirmed that Jetpack comments are toggled to inactive.

    Still getting the "Comments are closed" message where the Disqus / comments form used to be.

  2. kmessinger
    Forum Moderator
    Posted 3 years ago #

    Try disabling jetpack.

  3. patocka
    Posted 3 years ago #

    Disabled Jetpack.

    Still getting the "Comments are closed" message.

  4. kmessinger
    Forum Moderator
    Posted 3 years ago #

    How about using the edit and checking discussion - upper right screen options if you don't see it.

  5. patocka
    Posted 3 years ago #

    I opened edit screen options and set the values:

    [x]Allow comments.
    [x]Allow trackbacks and pingbacks on this page.

    Updated test post. Still getting "Comments are closed."

  6. kmessinger
    Forum Moderator
    Posted 3 years ago #

  7. patocka
    Posted 3 years ago #

    Swapped out Thesis for the 2012 Theme. Still "Comments are closed."

    Played plugin bingo. Deactivated all plugins and reactivated one by one.

    "Comments are closed."

    I also did a complete fresh manual re-install of 3.5 on Wednesday of last week in trying to troubleshoot an internal server error issue, so I don't know if going through that process again is going to solve anything unless a fresh batch of upgrades has been released over the weekend.

    Save for the steps taken above, reading through the 3.5 master list you linked to, it doesn't appear that anything listed pertains to the issue I am having at the moment. Then again, if I am overlooking something please let me know.

  8. kmessinger
    Forum Moderator
    Posted 3 years ago #

    Thesis is a commercial theme and is not supported here. You should check their support forum. http://diythemes.com/

    [edit] I use Thesis 1.8.5 with no problems. Maybe you just need to upgrade.

  9. patocka
    Posted 3 years ago #

    Good idea. Upgrading to Stay tuned.

  10. patocka
    Posted 3 years ago #

    Tried to update to That was a disaster. Have a thread going to address that:


    Reverted to 1.85 just to see if the issue persisted. Still have the comments problem on the 1.85 setup.

    Right now I have it set on for DIYThemes to troubleshoot but 1.8 appears to be the only stable build for me right now.


  11. kmessinger
    Forum Moderator
    Posted 3 years ago #

    Go to the dashboard, thesis, design options, comment options and check the display settings. BTW your site is down now.

  12. patocka
    Posted 3 years ago #

    Thanks for the heads up. Its because I have 2.x selected. Switched back to 1.8. Found this:


    Tried ticking the boxes anyway, and hitting save just to see what happens.

    Got the following:

    Warning: Invalid argument supplied for foreach() in /home/content/p/a/t/patocka1868/html/blog/wp-content/themes/thesis_18/lib/classes/options_design.php on line 468

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/p/a/t/patocka1868/html/blog/wp-content/themes/thesis_18/lib/classes/options_design.php:468) in /home/content/p/a/t/patocka1868/html/blog/wp-includes/pluggable.php on line 876

    Not a WordPress issue. I'll log a new ticket with DIYThemes.

    This is likely whats causing the issue. Thanks kmessinger for your patience.

Topic Closed

This topic has been closed to new replies.

About this Topic