Support » Fixing WordPress » Comments missing / not working

  • Resolved angryguy40

    (@angryguy40)


    Hi All.
    I got up this morning to all of my comments missing. I did some reading here and tried the default theme and disabled all plugins, as was suggested in some posts. Even when I try to leave a comment, the page just hangs and does nothing. I have no coding ability, I wouldn’t know where to start. http://www.al-sucks.com
    Any Ideas?

Viewing 9 replies - 1 through 9 (of 9 total)
  • Maybe your wp_comments table is corrupted? If this is the case, you can login to your cpanel admin screen and repair the whole database.

    I have no idea what that means.

    Comments are stored inside a database file in your hosting server. Like many other things, it can fails (corrupted). But you can repair them from cpanel if it is corrupted.

    This was happening to me, when suddenly I lost all my posts. At first, I suspected that my blog had been hacked. But when, I manually query the database via phpMyAdmin, it tolds me that my wp_posts table is corrupted. Then, I repaired the whole database, and everything is back to normal.

    I saw similar experience from your explanation above, so… I think it is not harmful to try the same steps to fix it.

    I did the automatic database repair through yahoo site manager. The old comments are back but new ones still no longer work. I don’t know what to do.

    Is there some way I can pay someone to fix this? I really don’t have the time or the skills and just want this up and running again.

    Moderator James Huff

    (@macmanx)

    If you want to hire someone, post a job here:

    http://jobs.wordpress.net/

    It looks like your blog is also having some redirection issues, which are preventing me from even accessing a post and could be related to your problem.

    Try re-saving your permalink structure at Settings/Permalinks in your admin panel. If WordPress cannot automatically edit the .htaccess file, it will provide manual instructions after saving.

    Oh My, that was it. Thank you guys from the bottom of my heart. The db repair got all my old comments back yesterday and re-saving the permalinks got everything running again. What could have caused it? I did update a couple of plugins but that was several days before this. Any ideas?
    -Don

    Moderator James Huff

    (@macmanx)

    You’re welcome!

    It’s hard to say what caused it without detailed logs, but I’m going to guess that it was one of the plugins you updated or installed recently.

    Thanks again.
    I would have posted a link to macman but I know some people don’t care for the right wing slant. I did however post a thank you to both of you.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Comments missing / not working’ is closed to new replies.