Support » Fixing WordPress » Comments link not working on main page?

  • Hey everybody!

    I’m pretty new to using wordpress and could use some help with my blog. It seems the comments link isn’t working on my main page. When you click on it, it doesn’t go anywhere or attempt to load the post’s page.

    The link looks fine and when I copy and paste it into the address bar it works. Only time when it doesn’t work is when I try to click on the link in the main page. I’ve seen it work on a demo site where I grabbed the theme. Tried it at home on Vista + IE at home and Linux + IceWeasel at work.

    I’m using version 2.6.3 and the charcoal (2-column) theme.

    Here’s a link to my blog: Pursuit of Character

    Any help would be very much appreciated! 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • Bump

    Sorry for the bump, but I could really use some help on this. 🙂

    When you click on any of the comments links on the main page, it should take you to that post’s page and down to the comment section right?


    Interesting update, earlier youtube was running slow (i have a few youtube videos embedded using the smart youtube plugin) and when I clicked on the comments links on the index page during this time it worked fine.

    After youtube fixed whatever problem it was having, my index page loaded normally and the comments links stopped working.

    So on a hunch, I reloaded the index page and quickly clicked on the comments link before the page fully loaded and it worked! So that leads me to believe that there is might be something wrong with the index page somewhere. I disabled the plugins, deleted my posts, and the problem remained.

    Below is my index.php. I’d really appreciate any help on it. I have no idea how a click on a link won’t register at all.

    <?php get_header(); ?>

    <?php get_sidebar(); ?>
    <div id=”content”>
    <?php if (have_posts()) : ?>

    <?php while (have_posts()) : the_post(); ?>
    <div class=”post” id=”post-<?php the_ID(); ?>”>
    <div class=”title”>

    <div class=”time”><span> <?php the_time(‘F-j-y’); ?> </span></div>

    <h2>” rel=”bookmark” title=”Permanent Link to <?php the_title(); ?>”><?php the_title(); ?></h2>

    <div class=”date”><span>posted by <?php the_author(); ?></span> </div>

    <div class=”cover”>
    <div class=”entry”>
    <?php the_content(‘Read the rest of this entry »’); ?>
    <div class=”tags”><?php if (function_exists(‘the_tags’)) { ?>Tags: <?php the_tags(”, ‘, ‘, ”); ?>
    <?php } ?></div>


    <div class=”postmetadata”>

    <div class=”alignleft”>#comments”>Comments (<?php comments_number(‘0′,’1′,’%’); ?>)</div>
    <div class=”alignright”> TOP </div>

    <?php endwhile; ?>

    <div class=”navigation”>
    <div class=”alignleft”><?php next_posts_link(‘« Previous Entries’) ?></div>
    <div class=”alignright”><?php previous_posts_link(‘Next Entries »’) ?></div>

    <?php else : ?>

    <div class=”post”>
    <h1 class=”title”>Not Found</h1>
    <p>YOU are looking for something that ISN’T HERE.</p>

    <?php endif; ?>


    <?php get_footer(); ?>

    After a bit of screwing around and comparing the code with the stock template. It seems the problem was with the permalink structure and the template not working together. For some reason it just would not work with the default permalink setting.

    Works fine now! 😀

    Now back to work to what I should’ve been doing… 😉

    What did you actually do to fix it? I am having the same issue…

    I went to Settings -> Permalinks and changed it to “Month and Name”, that ended up working for me. Whatever the reason is, the default one wasn’t working with the template I was using.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Comments link not working on main page?’ is closed to new replies.