[resolved] Comments link doesn't work, cannot read or add comments online. (3 posts)

  1. Olivier
    Posted 3 years ago #


    I am using WordPress 3.4.2 with the Etherna WP 1.2 theme to run a blog within a website. Everything works fine, except that the comments don't show when you click on the "No comments" or "x comments" link.
    You just end up on a new page with no comments, and no comment form!

    So basically, although it is possible to add comments through the admin panel, no one can read those nor reply.

    What have tried so far:
    deactivate all plugins --> only 1 running: WordPress Importer
    switch to the default theme and back to the Etherna one
    tried all the permalinks settings...
    re-install WP

    None of this does fix this problem.

    You can have a look for yourself at http://www.fojproject.com/news/ .
    Hope someone has an idea, I couldn't find anything on internet, besides the obvious (comments are authorised, anyone can post, no need to register...).

  2. Abhishek Ghosh
    Posted 3 years ago #

    switch to the default theme and back to the Etherna one

    That simply means the problem is probably not with your paid theme. The things behind comment form is :


    These posts might help you :




    Edit : I tested your Sapphires also are forever post webpage with Opera Dragonfly, apparently there is no comment div just like others had the problem.

  3. Olivier
    Posted 3 years ago #

    Hi Abhishek,

    Thank you for the prompt reply! Your comment did help me to solve this annoying issue.
    There was in fact a PHP error, but not where I though.
    My Single Post file (single.php) includes 2 other PHP files:
    1. single-blog.php
    2. single-special.php

    So I opened both files and added the missing reference to the "comments_template" at the end of the loop, just before the footer:
    '<?php endif; comments_template(); ?>'

    It works just fine now.

    I am sure it will be helpful to others to know that there is no such thing as a WordPress bug for this issue. It's just that some themes do not include the comments template in their PHP files. It's a bit silly as you can waste a lost of time, just as I did...

    Thanks again, you made my day! ;o)

Topic Closed

This topic has been closed to new replies.

About this Topic