WordPress.org

Support

Support » How-To and Troubleshooting » Comments in black on black?? How to fix?

Comments in black on black?? How to fix?

  • I installed and love this theme. The only issue is a reply or comment shows black text on a black background and it’s really unreadable. Is there an easy way to fix this?

Viewing 15 replies - 1 through 15 (of 23 total)
  • Sorry but I am talking about the Easel theme. I thought I was on the Easel board.

    Andrew Nevins
    Forum moderator

    @anevins

    Does that theme provide a section in the dashboard named something like, “Custom CSS”, or do you have a Child Theme of Easel?

    It has a section for editing CSS but there is NO CSS there. It evidently gives you the ability to add or modify the existing CSS but the existing CSS is not there nor would I really know how to do it. You can see the existing CSS by clicking a link but this is all foreign to me.

    I just think it should be easier to fix and not sure why that would be the default Black text on not quite so black background.

    Andrew Nevins
    Forum moderator

    @anevins

    If the option is not available through the dashboard, you may need to manually make those customisations by adding code.

    To avoid adding and editing the theme’s original files and losing your changes once you update the theme, you should be using a Child Theme or for simple CSS changes, a Custom CSS plugin.

    Once you have either, you can now query the exact CSS necessary through a more relevant forum.

    Not sure I understand that but thanks for your input.

    WPyogi
    Forum Moderator

    @wpyogi

    I thought I was on the Easel board.

    Here it is: http://forum.frumph.net/

    Frumph
    Participant

    @frumph

    What browser are you using that you see black on black?

    Internet explorer 9.

    Here is the page with the comment:

    Frumph
    Participant

    @frumph

    Yeah, IE9 .. fun

    What you’re going to need to do is open up the style-default.css file and search for this line:

    #comment-textarea:focus, #comment:hover, #author:hover, #email:hover, #url:hover, #comment:focus, #author:focus, #email:focus, #url:focus {

    and turn it into this line:

    #comment-textarea:hover, #comment:hover, #author:hover, #email:hover, #url:hover, #comment-textarea:focus, #comment:focus, #author:focus, #email:focus, #url:focus {

    And see if that works, apparently IE9 doesn’t like :focus

    If that does work, i’ll add it to the next 3.1.1 which i’m almost done with

    Frumph
    Participant

    @frumph

    ooo I see what’s going on, it’s not the black on black in the text area, it’s osmething else..

    ^ Thanks for the link, give me a second to give you the change

    Frumph
    Participant

    @frumph

    Here’s the deal.. .. Do you have some sort of plugin going on .. this spam free plugin that’s enabled at the moment?

    Could you disable that for a moment so I can look with it turned off?

    I believe it’s a plugin you have enabled that is causing it to lose all CSS entities

    esmi
    Forum Moderator

    @esmi

    @frumph: I’ve got a scrap of js that deals with :focus issues in older versions of IE. Drop me a line if you want a copy.

    Frumph
    Participant

    @frumph

    @esmi I tested the CSS with IE7 and IE8 – just not IE9 and it’s working nicely, .. but unfortunately that’s not the issue just the description of it threw me off.

    His problem is the grey background that comes with #content-wrapper {} is gone .. well the html element for ID=content-wrapper is gone completely .. as if some plugin is overwriting the comments section so the background isn’t showing

    Okay it’s deactivated.
    Thanks

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Comments in black on black?? How to fix?’ is closed to new replies.