Support » Fixing WordPress » Comments going straight to trash

  • Resolved denisebaer

    (@denisebaer)


    I’ve been having issues with blog comments going straight to the trash. I’ve removed all spam plug-ins, and under Discussion settings, I don’t have anything marked for moderation. I’ve already did a search about this topic, but none of them looked resolved. Please help!

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Your site is a WordPress.com site. We can not support that here. This forum is for self hosted WordPress.org sites only. Please check on your theme’s support page for help.

    Thanks. I opened an issue with them.

    I’ve posted in the theme troubleshooting area, but they suggested I post in the general troubleshooting for WordPress. I’m not sure if this is the area, and I don’t understand the difference between WordPress.com and WordPress.org. I thought it’s all of the same.

    Moderator Kathryn

    (@zoonini)

    Automattic Happiness Engineer

    @jaycbrf http://baerbookspress.com does not look like a WordPress.com site – it’s hosted on GoDaddy.

    If anyone has suggestions for Denise about her comment issue, please feel free to reply here, as I don’t think the issue is theme-related.

    Denise, let us know how it goes after trying the troubleshooting step I gave you in your other thread.

    • This reply was modified 1 week, 2 days ago by  Kathryn.
    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    @denisebaer As far as I know, WordPress itself doesn’t have any way to make a new comment go directly into the trash. Akismet can do that, if it thinks it’s spam and you have those options selected, but WordPress itself doesn’t have that built in.

    Does it happen immediately and instantly when the comment is made, or does it seem to happen more randomly?

    I’ve deactivated all my plugins, sent a comment from my phone, and it still goes directly to trash. I removed Akismet, because I wasn’t using it. Under settings – Discussions, I have nothing checked before a comment appears, nothing under moderation, and a few words under blacklist. That’s it! None of my plugins are activated now, but I thought maybe I should look for an anti-spam plug that might fix the problem.

    I recently checked under Users on my Dashboard and found a lot of subscribers. I deleted them. I’m at a loss.

    I’ve had people contacting me by email saying their comments were blocked. It wouldn’t even allow them to comment. These are people who always comment on my blog.

    I should clarify something. I created a post on October 16. One person, who is a regular poster, emailed me stating that the site blocked his post. He couldn’t even post and then he copied what he planned on posting, which didn’t have anything in it from my blacklist. At the time, I added his email address to whatever spam plugin I had (can’t remember which one).

    After that, I had many people comment without issue.

    Then I created a blog post on November 13. The person who had a problem with the October 16 post had no problem posting. Another person, who is also a regular poster, emailed me stating she was blocked from commenting. She couldn’t even comment. Since I deactivated my anti-spam plugins, I didn’t add her email address to any list. No one else, other than the first guy has left a comment. My husband and I have been sending comments from our phones. They’re not blocked but they go directly to Trash.

    Okay, I think that’s everything.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    It’s gotta be a plugin or something. Can’t see any other cause.

    Tell you what, email me about it, I’ll take a look at your site, if you will give me access. My email is otto at wordpress.org.

    Wow, personal service from THE WordPress man himself!

    Thanks, Otto. I sent you an email and you should receive another from my site with Administrator info. I appreciate your time.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.