Support » How-To and Troubleshooting » Comments form missing

Comments form missing

  • URL: http://brleader.com/

    I had disabled comments, but now am trying to re-enable them. In my localhost environment everything works fine, but on the live site the entire comments form doesn’t show up, even though the settings under Discussion and the single.php and comment-form.php templates are identical. The source code shows that there is no form, as if the function call is being ignored.

    It’s not a problem with the theme, because it’s the same problem with Twenty Ten. Deactivating all plugins had no effect either.

    I don’t know what else to look at. Any ideas? Thanks all.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Michael


    Forum Moderator

    you possibly need to enable comments for each post individually – either use quick-edit for each post in the ‘postsp page in admin;
    or – on the ‘edit post’ page – click the ‘screen options’ tab near the top right, tick ‘discussion’, then scroll down to below the post editor, and enable the comments for the post in the ‘discussion’ area.

    Please confirm if it worked fine when you applied comments to a single post manually?

    Thank you

    Yes, that was the problem! Thanks, alchymyth. I guess having disabled commenting made that the default for all the existing posts, so they have to be changed manually.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Comments form missing’ is closed to new replies.
Skip to toolbar