Support » Plugin: Comments - wpDiscuz » Comments for posts on static homepage

  • Resolved Sridhar Katakam

    (@srikat)


    Hello,

    I have the latest post appearing via a custom loop on a static front page.

    In wpDiscuz general settings, “Enable wpDiscuz on Home Page” has been switched on.

    <?php comments_template(); ?> does show the wpDiscuz comment form but the comments are getting attached to the Page that has been set as the static front page and not the post under which the comment form appears.

    When wpDiscuz is deactivated, submitting comments work as expected i.e., they get posted under the post appearing from the custom loop.

    Is there a way to make wpDiscuz interpret the comments as belonging to the post rather than the static homepage?

    Thanks in advance.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support gVectors Support

    (@gvectorssupport)

    Hi @srikat,

    It seems you’ve chosen the “Your latest posts” option, instead of the
    “A static page (select below)” one in “Your homepage displays” section.

    That is not the case.

    Screenshot: https://d.pr/i/wSmXya

    Actually, the comments area for the post in the custom loop on the static front page is not being impacted by wpDiscuz. When the static front page has “Allow comments” ticked only then wpDiscuz seems to load but then it is for that Page and not the individual post on that Page.

    Let me know if it is still not clear. I can record a screencast and share the link.

    Plugin Support gVectors Support

    (@gvectorssupport)

    Hi @srikat,

    We’re really sorry but you cannot do it. Even if you find a way to include the comment section, it’ll not work correctly. The comments will be messed, i.e. the comments from one post will be added under another post. No matter under which post is made a new comment it’ll be added for only one post.

    How about using “Pages”? Will wpDiscuz display comments/replies properly on assigned “homepage”? And would all features/functions of wpDiscuz still be available?

    Solved by changing the main query of homepage to that of the latest post using pre_get_posts.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.