WordPress.org

Forums

Comments for Pages (4 posts)

  1. danielmee
    Member
    Posted 9 years ago #

    I am trying to work out why I don't get the comment feature avaialble on any new pages I create using the WordPress install I have done through my account with Dreamhost (using their 1 click install feature).
    On the admin, in the write page, I have ticked "allow comments" in the discussion drop down on the right of the form - but when I view the page from the live site there is nothing?! How do I get the comment feature to be on the Pages?

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    You need to make a new 'page' template.
    http://codex.wordpress.org/Pages#Page_Templates

    You make one template with the comments code included and put (for instance)
    <?php
    /*
    Template Name: commentpage
    */
    ?>

    And you make another without the comment code (because sometimes no comments is good):
    <?php
    /*
    Template Name: Nocommentpage
    */
    ?>`
    Upload those to the theme directory and when you write a page you will have a choice of template.

    That help?

  3. danielmee
    Member
    Posted 9 years ago #

    Ummm, yeah... guess so - It is obviously more effort than I was expecting but if that's the way to do it then I will have to do it as we really need this option. Thanks heaps for replying and the advice seems very considered witht eh choice of template idea - thanks.
    (apologies for the delay, have been out of the office since my post.

  4. Bernard Bos
    Member
    Posted 9 years ago #

    Maybe you can try the <?php comments_template(); ?> code at the end of your page's script.

    But this is for all pages.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags