Support » Plugin: Comments Evolved for WordPress » comments evolved and autoptimize

  • Resolved appmarsh

    (@appmarsh)


    hello, i have a problem on my blog with comment evolved and autoptimize plugin, when i load autoptimize comments doesn’t show up, any ideas how to solve this ?

Viewing 6 replies - 1 through 6 (of 6 total)
  • you’re forcing JS in head appmarsh, which means you have JS-code that tries to access the DOM (HTML) before it is loaded, which is why you have

    07:51:05.968 TypeError: label is null 1 autoptimize_0faa2819b114169b3c7de456cfacf7e8.js:16:391

    you will either have to not force JS in head (you’ll probably have to add js/jquery/jquery.js to the JS exclusions) or exclude one or more files from JS optimization.

    frank (ao dev)

    Thank you for answer,

    added “js/jquery/jquery.js” but nothing changed about comments,
    now i’m thinking about one more file,
    but don’t how to add comment evolved exclusions,
    can’t find anything, and don’t know what to look for 🙁
    would be thankful for any help 🙂

    you forgot to uncheck the “force JS in head”-option 🙂

    Thank you for notice and support,

    so unchecked “the force JS in head” option
    autoptimize appmarsh.com option img

    also added this list “jquery.js, seal.js, jQuery-UI-Tabs.js, adsbygoogle.js, e-201702.js, devicepx-jetpack.js, bootstrap.js, jQuery-UI-Core.js, analytics.js, osd.js,”

    but comment evolved doesn’t work.

    • This reply was modified 3 years, 1 month ago by appmarsh.

    Figured out that with autoptimize everything seems to be ok, conflict is with other plugin, trying to find out. Thank you for support Frank 🙂

    thanks for the update @appmarsh, indeed noticed (had the tabs open already but did not have to to investigate in detail yet) that the page without autoptimize (add ?ao_noptimize=1 to the URL to disable AO) did not show comments either.

    have a nice day (well, evening),
    frank

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘comments evolved and autoptimize’ is closed to new replies.