Support » Themes and Templates » Comments don’t work properly in Firefox (IE fine)

Comments don’t work properly in Firefox (IE fine)

Viewing 6 replies - 1 through 6 (of 6 total)
  • Nobody can see code on an image…

    ohh sorry m8 !!!!
    i’ve completely forgotten it.

    <!– You can start editing here. –>

    <?php if ($comments) : ?>
    <h3 id=”comments”><?php comments_number(‘Keine Kommentare’, ‘Ein Kommentar’, ‘% Kommentare’ );?> zu “<?php the_title(); ?>”</h3>

    <ol class=”commentlist”>

    <?php foreach ($comments as $comment) : ?>

    <li class=”<?php echo $oddcomment; ?>” id=”comment-<?php comment_ID() ?>”>
    <cite><?php comment_author_link() ?>:</cite>
    <?php if ($comment->comment_approved == ‘0’) : ?>
    Your comment is awaiting moderation.
    <?php endif; ?>

    <small class=”commentmetadata”><?php comment_date(‘F jS, Y’) ?> at <?php comment_time() ?> <?php edit_comment_link(‘edit’,”,”); ?></small>

    <?php comment_text() ?>

    <?php /* Changes every other comment to a different class */
    if (‘alt’ == $oddcomment) $oddcomment = ”;
    else $oddcomment = ‘alt’;

    <?php endforeach; /* end for each comment */ ?>

    <?php else : // this is displayed if there are no comments so far ?>

    <?php if (‘open’ == $post->comment_status) : ?>
    <!– If comments are open, but there are no comments. –>

    <?php else : // comments are closed ?>
    <!– If comments are closed. –>
    <p class=”nocomments”>Comments are closed.

    <?php endif; ?>
    <?php endif; ?>

    Hopefully you can find and fix the problem.

    What I really meant is a link – so the helpers can see for themselves (and edit online) your css file, since that kind of display error must be caused by faulty stylesheet.

    ok, finally i see 😀

    here we go:

    If someone can help me, please register and edit the stylesheet under PRESENTATION / THEME EDITOR !!!!





    my last comment, i believe #26 looks equally shitty in ie7.

    I am assuming you mean that it looks OK in ie6.

    your problem lies in this:

    .alt {
    	margin: 20px 0 10px 0;
    	padding: 10px;
    	height:50px;  <--------------------------

    remove that from your CSS and see what happens.

    WOW – thanks a lot whooami !!!!
    No it looks great in IE7 !!!!

    (sry for assuming firstly it looks good in IE7 – that was wrong !!!! it was the same mistake with IE like in Firefox)
    Moreover, after having changed some of the paddings, it even looks good in Firefox!!!!

    so everything’s fine now!!!!
    THANKS AGAIN m8 !!!!


Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Comments don’t work properly in Firefox (IE fine)’ is closed to new replies.
Skip to toolbar