Support » Fixing WordPress » Comments do not appear to be working (since upgrade to 1.5)


    When going into a comment page it brings up the archived version of the post with the options near the bottom to make a comment — after I click the “leave a response” link nothing appears to happen. I followed the instructions on how to upgrade very closely so I don’t think I did anything wrong there. I can’t figure out what is going on and all of the other posts about comments not working when upgrading seem to be related to the popup comment box — which I never had enabled in the first place.

    Any ideas on how to get comments functioning again?

    The file names in my kubrick theme directory (which is enabled) is comments.php and I went ahead and tried to copy it to a new file, wp-comments.php, and upload it and see what happens…but it didn’t work either.

    Thank you.

Viewing 15 replies - 31 through 45 (of 65 total)
  • More of us with the same problem – no field to input name/email:

    No solution yet~

    One thing…I installed the “GreenTrack” theme, and my comments work no problem, but in “default” and a couple others, it doesn’t work…

    The problem may or not be related to the mysql data base.

    I have found that by dropping the tables from the data base and “reinstalling” — just by running install.php over the old system — I can get the comment function to work, at least temporarily.

    Will have to keep testing to see if it breaks again.

    Good luck.

    “An original posting is accompanied only by a “0 comments” link. Click it and you get a comment posting box. Fill it in and submit, and the page pretty much recycles.”

    This is exactly what happens to me. Went from 1.2.1 to 1.5 – tried backing up the database and restoring it. Fresh install with a new database is fine; as soon as I import my old, new comments continue to be impossible.

    Any progress?

    Any developers looking at this problem?

    I’ve solved my problem, but there seem to be a number of different ones here so it probably doesn’t matter much. Mine was that when I split my old index page into Header, Sidebar etc. the comments stopped displaying – comments_template(); did nothing.

    The solution was to take the line $withcomments=true; out of the header.php file and put it in the index.php file.

    I hope this helps somebody.

    (Sorry – accidentally double posted).

    There definitely seems to be more than one problem going on to cause this. I hope some people in the know are actually troubleshooting this.

    In our case the problem was solved by making sure that the Blog Address and WP Address was the same — my blog is in a subdirectory. And I am seeing other problems besides this one that seem to indicate that WP 1.5 has issues with blogs not being at a particular location. So I think there’s probably an overall issue or two that need to be fixed, that might contribute to fixing a lot of these other problems people are seeing. Unfortunately I am not skilled enough to figure it out myself.

    Hmm. My blog is in the root directory; I think it’s a database problem, because a fresh database works fine with the same install… just the upgraded/updated one fails to record new comments.

    Any chance that there is a developer even looking at this issue? I’d feel a bit better if one of the guys would weigh in even if it is to say “I’m looking into it”.

    This silence is scary.

    My comments are not working either now. I’m wondering if I got blocked because I put a spammer into that list in my options – the one below where you can add spam words. I put in and I’m wondering if it is reading part of the url and blocking everything from the comments. I know it said that it could use part of the word, but I wasn’t thinking at the time that it could take www perhaps instead of the whole url as one thing.

    If this is the case, where can I edit that list – that is the only one I added to it and I’d like to remove it to see if the comments will work again.

    Thanks for your help.

    My installation was a fresh install since I just began using WP. I had 2 different spam plugins activated-I inactivated one-now my comments work? So if you’re having problems, and have spam plugins activated-try inactivating and see if this solves any problems.

    I didn’t activate any spam plugin, I put the url into Comment Blacklist under Options — Discussion.

    I have the following plugins activated: Auto-Close Comments (after 5 days), Customizable Post Listings, Gravatar, Who is Online, Recent Comments, Content Show/Hide with javascript, and WP Plugin Manager.

    Could someone tell me where I can edit that blacklist in case that’s the problem?

    So THIS is the train I should have been on. đŸ˜‰

    Man, this has been frustrating, BUT I think I’m making progress due to the comments made here. I decided to delete my .htaccess file (updated the permalink structure with nothing in the file), and I was able to get to and make a comment.

    However, I’m still not seeing the fields for name, email and URL. Is there a fix for that?

    The comments were working up until I added that spam site to the blacklist, that’s why I’m thinking that that’s what caused it.

    However, I’m open to other fixes… although I’ve tried everything suggested in this thread.

    I just checked in phpadmin and saw that all the “test” comments that I’ve put up there, are showing up as spam under the ‘comment-approved’ column. So it seems they have automatically been relegated to spam, cuz I didn’t mark them in the ‘awaiting moderation’ spot, and they never showed up anywhere else – other than in my db table.

    Again, I think I need to edit that comment blacklist – can anyone tell me where to do it?

    jafer – are you referring to the wp-blacklist plug-in?

Viewing 15 replies - 31 through 45 (of 65 total)
  • The topic ‘Comments do not appear to be working (since upgrade to 1.5)’ is closed to new replies.