Support » Fixing WordPress » Comments do not appear to be working (since upgrade to 1.5)


    When going into a comment page it brings up the archived version of the post with the options near the bottom to make a comment — after I click the “leave a response” link nothing appears to happen. I followed the instructions on how to upgrade very closely so I don’t think I did anything wrong there. I can’t figure out what is going on and all of the other posts about comments not working when upgrading seem to be related to the popup comment box — which I never had enabled in the first place.

    Any ideas on how to get comments functioning again?

    The file names in my kubrick theme directory (which is enabled) is comments.php and I went ahead and tried to copy it to a new file, wp-comments.php, and upload it and see what happens…but it didn’t work either.

    Thank you.

Viewing 15 replies - 16 through 30 (of 65 total)
  • I just tried a fresh install and it works fine, but if i drop all the tables and insert all the tables from my backup the comments dont work anymore, is there a difference in how 1.5 calls comments from the database.

    my comments don’t work at all, in any theme.

    Ok i have narrowed it down to something being wrong within the option table in the database.

    I drop table by table and replaced it with the backup and only when the option table was inserted did the comments stop working.

    Does any have any ideas of what would be causing this.

    Okay, i dont know if this would cause the problem but the table strutures are different from 1.2 to 1.5, in 1.2 in the comments table USER_ID was 4th from the bottom, but in 1.5 it is last. this might be casuing the problem.

    i have a possible solution after a full night of troubleshooting. after several clean installs of 1.5, my comments would not work at all. i finally decided to delete the blank index.htm file from root directory (i kept it there to hide my work in progress). comments work perfectly now.

    Wow nice find, but now i am stuck, my word press install is in a subdomain, i used ,htaccess to redirect to the subdomain.

    I removed the redirect and everythign works fine, I then tried to use a simple html page with a meta re-direct, and now the comments dont work again. So for wordpress to work it needs to be in root.

    that’s the theory i’m leaning toward. perhaps a server guru will drop a final solution on us.

    I thought I posted a reply to this earlier, but it’s not here… maybe I posted to another thread and can’t find it now… anyway, WP runs fine in a subdirectory — it’s just that in Options>General, the WordPress address and Blog address now apparently have to be the same. Which is a bug, I think.

    My blog is in a subdirectory (, but the Blog address used to point at root (, because there’s an alias there that sends people to the blog directory. And when I ping Pingomatic and other similar services, I ping them with the address, because that’s the address I’ve used for years and the one with which I’m listed on most people’s blogrolls. So the old way this used to work was fine. But now that I have to set the WP Address and the Blog Address to be the same, the automatic pinging no longer pings the correct address. For the time being I am manually pinging.

    Nope that doesnt fix it

    I am having the exact same problem. Posts display, but do not offer any place to make a comment. The only thing I see is an “edit” which you can edit the post with. I am relatively new to WordPress, and have been trying to tweak the code.

    The best way, which isn’t exactly a pretty way of doing it, is to grab index.php from the classic theme and copy it over. From there, you can tweak it to get it looking right.

    Hopefully, this will fix your problem.

    I was able to get mine working by using a javascript to redirrect my domain to my subdomain and it seems to have fixed the problem.

    Thats to all the suggestions

    I have the lack of fields syndrome. . . . users seem to have problems posting because the email and name fields are required but don’t show up for them… I think it has something to do with WP thinking they’re logged in as admin, but they’re not! AAAAAHHHHHH soooo frustrating! And I’m a php noob so I don’t know how to fix the stupid thing!


    Same problem here. Have re-installed the script files, and have used several themes including the defaults. Have made it as easy as possible for someone to post — no limits. Have tried to post as admin and as a registered user.

    An original posting is accompanied only by a “0 comments” link. Click it and you get a comment posting box. Fill it in and submit, and the page pretty much recycles.

    Have never been able to see a comment, or get one recognized by any part of the management console.

    Spen a lot of time learning the new design features; never thought a problem like this would make the blog unusable.

    Help would be nice… but I see a lot of other folks are stumped.

    By the way…. is it possible for a registered user in this discussion forum to change his password?

    The comment box comes up. If I just click on the submit button I get:

    Error: please type a comment. on a completely blank page.

    Otherwise I just get a totally blank page.

    Both times the page in the address bar is:

    For me, the upgrade went painlessly until I completely embraced the themes. I split my Index page into Header, Footer Sidebar etc. Then my comments stopped working – nothing shows up. I tried replacing the comments.php file with the default, but it made no difference. My comments.php file worked fine before, and it still works fine on my single.php page.

    Is it something to do with calling it mulitiple times on the page? I don’t like using the popup. I use ScriptyGoddess’ show/hide comments, which works fine. _Worked_ fine. I’ve tried the other suggestions in this thread (those I understood). Anybody?


Viewing 15 replies - 16 through 30 (of 65 total)
  • The topic ‘Comments do not appear to be working (since upgrade to 1.5)’ is closed to new replies.