WordPress.org

Support

Support » How-To and Troubleshooting » Comments do not appear to be working (since upgrade to 1.5)

Comments do not appear to be working (since upgrade to 1.5)

  • http://www.deadafterdark.com/xarquid/wordpress/

    When going into a comment page it brings up the archived version of the post with the options near the bottom to make a comment — after I click the “leave a response” link nothing appears to happen. I followed the instructions on how to upgrade very closely so I don’t think I did anything wrong there. I can’t figure out what is going on and all of the other posts about comments not working when upgrading seem to be related to the popup comment box — which I never had enabled in the first place.

    Any ideas on how to get comments functioning again?

    The file names in my kubrick theme directory (which is enabled) is comments.php and I went ahead and tried to copy it to a new file, wp-comments.php, and upload it and see what happens…but it didn’t work either.

    Thank you.

Viewing 15 replies - 1 through 15 (of 65 total)
  • Are they showing up in your Awating Moderation list?

    Nope, I disabled all of those features.

    Under OPTIONS/DISCUSSION I made sure:

    # An administrator must approve the comment (regardless of any matches below)
    # Comment author must fill out name and e-mail
    # Comment author must have a previously approved comment

    Were all disabled/unchecked.

    I can’t even get the comment box/form to come up for me on my own page. It just doesn’t load or do anything when I click that link.

    In 1.2.2 I used to click on the NO COMMENTS (or the amount of comments) and it would immediately come up with the comment form by using the goto (#comments) function, I believe. Now I can’t even get the form to appear using any of the links.

    Fixed it. I just enabled the new default (kubrick anyways) and copied over my images…I think it had something to do with the way it handled headers in 1.5….either way it is working now!

    Thanks for your help.

    Ah – good work :)

    Thanks for your help 🙂

    It could have been what I was blithering about here:
    http://wordpress.org/support/topic.php?id=23495#post-132916
    (it turns out, though, I was off-topic – the rest of the post is about something else).

    On your old comments.php, was there an include statement for wp-blog-header? It’d be good to know if that was the problem.

    I had the same problem. My old commments.php file did not have an include statement for wp-blog-header, but it just did not work. I replaced it with the comments.php file from the default theme, and voila! problem solved. So, if comments are the only broken part of your theme, try changing the comments.php file (backup your old one just in case, though).

    I thought everything had gone smoothly with my upgrade to 1.5, but I am having the same problem with comments. I have tried copying over comments.php from the Classic theme folder to my Carrots (nice one!) folder – but it hasn’t fixed it, and now I think I can definitely say… I’m stuck!
    :o(
    http://www.miaowthecat.com

    Oh. And in my old comments.php there is no mention of wp-blog-header.

    I am having the same problem. I just did a fresh install of WordPress but can’t get comments (even the example one that comes with the fresh install) or the comment form to display. I have downloaded, installed and tried various other themes but with no luck. Am I missing something? Anyone have any ideas or suggestions?

    I am using IIS and have gotten permalinks working. This is the only major thing left (well other than the inability to do file editing with the admin – but that’s minor and probably due to my hosting being on windows) and could really use some help or suggestions.

    I’ve had the same issue, but I’ve just replaced my comments.php by the default one, and it works !
    if your are logged as admin or member, there is just a “leave a message” box (no email required, no url) but if you want to comment without being a member, you will have to enter your name, url and email (according your admin configuration)
    It works fine now !!!
    I’m also able to view my old comments !

    I hope this helps !

    Comments worked fine for me right from when I updated from 1.2.1 to 1.5, including all my old comments and a few spam comments that were awaiting moderation!

    No – I’ve tried replacing from the ‘Classic’ themes folder and the ‘Default’ folder and have had no luck. I am completely without comments. I can see if a comment has been left, but if I click on ‘comments’ it reloads the page in question and comments don’t appear – it’s like they’re not even activated. I have no idea what to do.

    Ok i have done everything that has been suggested and i cant get my comments working again. I did a search within both the themes and neither has a wp-blog-header in it.

    Just adding my two cents: did an upgrade to 1.5 (from 1.2) with no apparent problems…but comments don’t seem to be working with some Themes (bionic), but do work with others (default). But even when comments do work, the # of comments still shows as “0” on the main page.

    Ideas?

Viewing 15 replies - 1 through 15 (of 65 total)
  • The topic ‘Comments do not appear to be working (since upgrade to 1.5)’ is closed to new replies.