Support » Fixing WordPress » Comments disappeared, can’t post new ones

  • Resolved RotorGoat

    (@rotorgoat)


    Hi all,

    Been using WordPress for years without hitch. I recently however upgraded to 2.9.1 and nobody can now post comments. If I try to post a comment, the page goes blank (on this url http://eastlower.co.uk/wp-comments-post.php#comment-)

    Worse, all my previous comments from 606 posts appear to have disappeared (at least it says they have on the dashboard).

    I’ve contacted my administrator who says my database in phpmyadmin is fine – though the comments table says ‘in use’.

    I’ve reinstalled 2.9.1 manually, I’ve changed themes, I’ve de- and re-activated Akismet.

    And now I’m stumped.

    All advice welcome. Thanks in advance.

    Blog is http://eastlower.co.uk

Viewing 6 replies - 1 through 6 (of 6 total)
  • esmi

    (@esmi)

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-related problems?

    resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

    Thanks Esmi – really appreciate your help.

    I haven’t tried deactivating all plugins – will try that now. Nor have I tried resetting the plugins folder so I’ll try that too.

    The other two things I have tried, to no avail. Changing to the default theme had no effect and nor did re-uploading the wp-admin and wp-includes folders.

    Hi again,

    I’ve fixed it by repairing my mySQL database within my cpanel.

    I’m guessing either a) upgrading to 2.9.1 or b) updating a plugin had a negative effect…

    All fixed now though. Thanks for your help.

    Hi RotorGoat

    How did you repair the database in the cpanel? I have the same problem as you, so any help would really be appreciated.

    In Cpanel click on MySql Databases. On the next page you should see your MySql DBs. click on the “repair” button for the db you are using for your site. Hope it helps. Worked for me and I had the same problem.

    marcyf64

    (@marcyf64)

    I am now having this same problem – where is the Cpanel?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Comments disappeared, can’t post new ones’ is closed to new replies.