Support » Theme: Astra » Comments disappeared after activating Astra theme

  • Resolved ivangil

    (@ivangil)


    I am using Astra theme free, Elementor free, and wpDiscuz on my website.

    My website was showing comments on all pages until I migrated from OceanWP to Astra theme. After the migration, it completely stopped showing comments.

    I had to migrate because OceanWP was giving me many problems with Elementor and after a lot of research, Astra appears to be my best choice.

    In my website, Settings > Discussion > “Allow people to post comments on new articles” is checked. Still, I unchecked it, saved, checked it back, and saved again. It didn’t help.

    I tried deactivating all plugins but Elementor -it is required for the site to work- but it didn’t help.

    Also, I tried allowing comments in all my pages in bulk, but it doesn’t help either.

    I tried to isolate the problem using Plugin Detective but it didn’t find it.

    Most articles related to comments in WordPress are about how to disable them, not about how to force them to show.

    Any ideas are going to be appreciated.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • I found the cause of my problem:

    OceanWP theme supports the use of Elementor Full-Width template and still it shows comments if configured to do it, however, Astra, Neve, and Layers do not support that.

    I configured the pages to use the Default template and that solved my problem.

    I believe it is a problem with the Elementor Full-Width template. It is interesting that not even Layers works well, even though that Layers is now a property of the Elementor’s creators.

    Hi @ivangil ,

    That’s strange! Just to let you know that by default our theme adapts the fullwidth layout when the user creates the page with any page builder.

    But, I am glad that you figured it out and get your workflow on track.

    Regards,
    Deepak

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.