Support » Fixing WordPress » Comments Closed Automatically. Discussion Settings NOT Working

  • Hi,

    In my site Gtricks Comments are autoamtically closed for some posts. At the bottom of some posts “Comments are closed” is written but for other pages, neither there is anything written or comment form present 🙁

    After troubleshooting, I am still unable to solve. I have done –

    #1. Under discussions settings I have checked “Allow people to post comments on new articles” saved settings thousand times, then too no use.

    #2. Double checked wp_posts comment_status = ‘open’
    then too no use.

    For your information, i have nothing posted since July 🙁

    What can be reason, and how to open comments again?

Viewing 15 replies - 1 through 15 (of 15 total)
  • esmi


    Forum Moderator

    Can you post links to specific pages on your site that show both situations?

    Page with nothing written – Transfer gmail accounts

    Page were “Comments are Closed” written – Google earth easter egg

    BTW, thanks for quick response. I love WP Community 🙂



    Forum Moderator
    Although this has comments, there’s no comment form – which suggests that comments are actually closed for this post too.

    Have you checked your settings in Admin->Settings->Discussion? Have you set an automatic comment close period on that page?

    Yes, as I told you before, I have double checked there is no automatic close on comments. Previously, everything was fine but suddenly all comments forms were removed 🙁

    should I send u an snapshot of settings?



    Forum Moderator

    should I send u an snapshot of settings?

    Hey – I trust you. 🙂

    Maybe there’s something funky going on in either your theme or one of your plugins. Have you tried:

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Ten theme to rule out any theme-specific problems?

    Let my try these. Esmi, is there any way to contact u directly?

    I have tried both.

    I have deactivated all plugins – nothing happened

    I have switched to default theme – nothing changed.

    Any other troubleshooting step?

    Hi, I’m having the same trouble as abhis2.o. I have been posting on my wordpress blog for over a year and all of a sudden a couple of days ago every post has (comments on this entry are closed) and all my comments have disppeared. I have done nothing out of the ordinary BEFORE this happened I swear!
    SINCE, I have deactived all plugins – nothing, checked settings in Admin->Settings->Discussion – the default settings show Allow people to post comments on new articles. The only thing I have done is done a manual bulk override under posts for the first 20 of 300 odd posts I have done on my blog. Is this the only way I am going to be able to get around the problem and does anyone have any idea why this would have happened??
    Many many thanks in advance for any help or advice anyone can give. Hope you all had a Merry Christmas
    Elaine @ Destination Art Western Australia

    Just an update on my above posting. I have opened my blog today to find the 20 posts that I manually checked to accept comments has now reverted back to showing as “comments on this entry are closed”.
    Any thoughts would be greatly appreciated.
    Elaine @

    Hi Welovetim, I dont suppose manually overwriting things has some effects on comments.

    Can you tell me the name of all plugins that you are using on DestinationArt? Probably we can figure out the common culprit plugin.

    I just upgraded to the new WordPress and my comments are closed now, too. I hate going back thru all of them individually to open them. Oh, and my settings say I want all comments opened all the time. Something has changed with the update – some default — and I have checked both my theme settings and the WordPress settings. I am at

    Hi abhis2.0
    thanks for your comment, after manually overwriting all comments again, we seem to be back in business. Although we did need to enlist the help of a professional wordpress troubleshooter to do this for us.

    barfmc – this is the advice our troubleshooter gave us:
    There’s a little Screen Options box in the upper-right corner of the page when viewing the list of posts in the administrative side. Change the number of posts to however many posts that you have in total on your blog. Then select them all and choose Edit, then select to turn comments on. This should make all comments re-appear. Much quicker than doing it 1 by 1!!!!
    Cheers Elaine @ Destination Art

    Thank-you! All changed, now. Great help. 🙂

    Thanks from my side too, welovetim. Your advice worked like a charm.

    By the way, DAB – Destination Art Blog is really inspiring. I couldnt find contact me page their so I am appreciating you here for such creative pieces. Only one complain, please shorten page length. It took ages for me lo load the entire page.

    Thanks welovetim. This works!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Comments Closed Automatically. Discussion Settings NOT Working’ is closed to new replies.