WordPress.org

Support

Support » How-To and Troubleshooting » Comments causing excessive load times

Comments causing excessive load times

  • Flyschool
    Member

    @flyschool

    Problem: 300 comments + being added to the bottom of a post is causing excessive load times.

    Resolution i’m looking for: To remove comments from posts and replace them with a “view comments” link. I need the link to open the comments on the same page, perhaps in a hidden div ?

    Hard problem to look up, i keep getting “archives” related answers, i need this resolved ON the post itself, not on the archive pages. I’m using cutline theme if that helps.

    Any help appreciated, problem is urgent.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Flyschool
    Member

    @flyschool

    Scratch that message, I need the solution to be a link that when clicked opens the comments and comment submit form in a new window.

    I personally like the ‘Paged Comments’ plugin:

    http://www.keyvan.net/code/paged-comments/

    I have a couple of posts with over 1000 comments, and it does a great job handling them. There are several options as well.

    Example (copied from my site):

    Pages: [31] 30 29 28 27 26 25 24 23 22 21 … 1 » Show All

    Flyschool
    Member

    @flyschool

    Anyone? How do I add a “view comments” link on posts (not archive or main index, actual posts)that brings up the coments/comment submit form in a new window ONLY when someone wants them to show up?

    If your chosen theme displays comments on the front page, your theme is at fault. Fix it or pick another. I’ve never seen one that displayed any comments on the front page but everything is possible.

    Switch to the default theme for a few minutes. All better? or have we missed something you haven’t explained.

    Or take the plugin code you were referenced above and your favorite HTML primer and look for the ‘window’ attribute and modify your theme or plugin or both.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Comments causing excessive load times’ is closed to new replies.