Support » Theme: Montezuma » Comments box not showing on all pages

  • How can I put a comment box on pages where it’s not showing?
    Is there some logical reason, like something I’ve done, that accounts for the comment box not consistently showing?

Viewing 7 replies - 1 through 7 (of 7 total)
  • have you checked all settings?

    I’ve never checked settings. On any of my sites. What settings ?

    I’m sorry you can’t help.

    Hi, Karen. Hope all is well. If you go to Settings → Discussion from the admin dashboard, you want to make sure that Allow people to post comments on new articles is checked if you want the comment box to show up on any new pages that you create. If you don’t want the comment box to show up by default, then leave the box uncheccked, and you can selectively choose which pages to allow comments (see below).

    If you have existing pages or posts where the comment box is not showing up, go into the page or post editor and scroll down until you see a section labeled Discussion. If you don’t see such a section, then click the Screen Options tab in the upper right corner and check the box labeled Discussion and it should appear. Then check the box in that section that’s labeled Allow comments and the comment box should appear for that page/post.

    Hi CrouchingBruin, What a delight to see you.
    I’ve now checked each site, and they’re all correctly set.
    Maybe it was a temporal problem. Today each site appears to have the comment box.
    Thank you 🙂

    Hi, I have restored the site but still the default wordpress comment box is not displaying on every post. I have also installed Facebook comment plugin and both should show as they used to before.

    I do not know what happened but I still could not get the wordpress comment back.

    My site:

    @crouchingbruin: Thank you very much for your explanation, it helped me figure out the problem!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Comments box not showing on all pages’ is closed to new replies.