Support » Theme: Ignite » Comments Box Not Showing

  • Resolved sfield981

    (@sfield981)



    I have a Leave A Comment link below my first published post on the Home page, but it doesn’t lead to anything when clicking on it and there’s no Comment Box for readers to leave comments on the post page. Can you tell me what settings I need to correct in order for this to show up. THANKS!

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Theme Author Ben Sibley

    (@bensibley)

    Thanks for using Ignite!

    In your Discussion settings (Settings > Discussion), make sure this setting is enabled to allow comments: http://pics.competethemes.com/nKDW

    Next, visit the post in your dashboard and make sure comments are enabled for the post in the Discussion box: http://pics.competethemes.com/nK4y. You should see the Discussion box below the post editor, but if you don’t, click on the screen options tab at the top and check off the Discussion box first: http://pics.competethemes.com/nLK1

    Once comments are enabled, the “Leave a comment” link will take visitors to the comment form on the post where they can leave new messages.

    Thanks for the reply! I confirmed all 3 of those suggestions prior to my inquiry and no luck with the Comments box coming up. What else could be missing for settings? The Leave A Comment link is still not leading to a Comment form for visitors. Appreciate any other insight!

    Theme Author Ben Sibley

    (@bensibley)

    Okay thanks for checking those. I forgot one more setting – Ignite has a comment display feature in the Customizer (Appearance > Customize > Comments). Make sure the posts are checked off there to display comments: http://pics.competethemes.com/nKjB

    I also have had All Selected (Posts, Pages, and Attachments) in the Customizer as well. Still no redirecting to the Comment form when clicking on Leave A Comment. Any more ideas? THANKS!

    I just noticed in my next post that I was reviewing for publishing in Draft format and it doesn’t have a Comments choice is the Screen Options, BUT my post preview has a Comments form available at the end of the post. I don’t why the Screen Option choices are different between the 2 posts and I’d like to replicate it for my first post to make the Comments form available, but it doesn’t seem to have any effect on the first post whether I check Comments or not or how to even get rid of it as a choice like my next post’s Screen Options choices. Any thoughts on this? THANKS!!

    Theme Author Ben Sibley

    (@bensibley)

    I just visited the site and I now see the comment form displaying for both posts. Have you found a solution, or is it still not displaying when you visit?

    Somehow or another I played around with the different comments and discussions choices and was able to get it working so I think I’m okay now. Thanks for the help!!

    Theme Author Ben Sibley

    (@bensibley)

    Great, glad it’s working now 🙂

    I like your topic. it is more useful and helpful for me and for my team. Because we don’t know this trick. more details here lumion crack

    Theme Author Ben Sibley

    (@bensibley)

    Mods: please delete spam comment, thank you!

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.