Support » Fixing WordPress » Comments automatic set to “needs to approved”

  • Resolved Necro



    I’ve been messing with WordPress, and it everything runs smooth expect 1 thing.

    When an anonomous guy make a comment, lets just say under the name “Brian” it automatic get set to it needs approvement by me? Why? Nothing seems to be wrong, but here is my code where it should inflict;

    <?php foreach ($comments as $comment) : ?>

    <li class="<?php echo $oddcomment; ?>" id="comment-<?php comment_ID() ?>">
    <div class="lightblue">ID#<?php comment_ID() ?> <?php comment_author_link() ?> skriver:
    <?php if ($comment->comment_approved == '0') : ?>
    Din kommentar bliver smidt ind, hvis godkendt.
    <?php endif; ?>

    Nothing seems to be wrong? Very weird.. – Try yourself by trying to comment a news on

    Thanks in advance.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Mark (podz)


    Support Maven

    Options > Discussion:
    Before a comment appears:

    What is checked there ?




    What have you set for Options->Discussion->Before a comment appears ?

    Im sorry, I missed a valid point ->

    I had checked this; Comment author must have a previously approved comment

    But thank you very much for your fast replies – Great software!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Comments automatic set to “needs to approved”’ is closed to new replies.