WordPress.org

Support

Support » How-To and Troubleshooting » Comments aren’t listed in the admin panel wordpress 2.5

Comments aren’t listed in the admin panel wordpress 2.5

  • knightcrawler2
    Member

    @knightcrawler2

    Installed a fresh copy of WordPress 2.5 then import a database file and everything seems fine until I noticed none of the comments are not listed in the admin panel comment list.

    Anybody have an solution or answer?

Viewing 15 replies - 1 through 15 (of 24 total)
  • I have the same problem, the commends show up on the actual blog, and they show up under the manage post page, but comments says: No results found. for “show all comments”

    Is anyone else having this problem? I have a feeling it is from people who started out with 2.3.3 or around there. I even tried export, deleted a post that had a comment, then import (so it would actually import something with the one missing) and that didn’t fix the problem. Is there some sql command I can do to fix a table or something?

    knightcrawler2
    Member

    @knightcrawler2

    I think I’m going to upload 2.5 again in a different folder and try again

    I fixed it! I went and read the error_log file from apache and it told me exactly what it failed to pull from sql. It told me “Key ‘comment_date_gmt’ doesn’t exist in table” so I went to the table it talked about and created that as a key. I tried that same thing before but I had the wrong table, I did it to an old table that I’m not using anymore since I have multiple instances now of wordpress.

    @jmfolcik:

    I have a feeling it is from people who started out with 2.3.3 or around there.

    I upgraded a v2.3.3 blog of mine 3-4 days back, upgraded it in 2 minutes(including backup etc) using Fantastico & it went ahead without any problems & is still running pretty cool 🙂

    Did you begin at 2.3.3 or did you upgrade from an older version to 2.3.3 previously before going to 2.5? I started at 2.3.3, and was missing the key in my database, as it seems others do as well.

    Dangerdom
    Member

    @dangerdom

    This sounds like exactly what I need, unfortunately I am not that great at understanding what you are talking about, I am a noob when it comes to the real in depth stuff. Can you describe it a little bit more in depth.

    Is it a file that I can edit?

    Do I have to be using Apache in order to achieve the desired results?

    Any and all help is appreciated.

    This is within your database, so if you are using microsoft sql or mysql, a sql admin tool is used to fix it. Someone can probably fix it remotely for you but I’m not at that skill level, I still need the GUI to do anything.

    eexlebots
    Member

    @eexlebots

    I had this same exact problem and jmfolcik’s solutions worked for me; from phpmyadmin I selected the database, then selected the wp_comments table and viewed it in “Structure” mode.

    Oncer there I selected the “comments_date_gmt” field and checked the “index” option. Once I did that and it reported a success I checked my WordPress site and comments were back with no errors!

    I did have to create an admin accoutn with higher privileges to make the change in the database, for some odd reason; but I didn’t have to change my site’s MYSQL login stuff in the wp-config file, which was good 🙂

    Thanks a million jmfolcik!

    phpmyadmin is blank when i try to use it. :/

    I hope this gets patched in the next version…

    Dangerdom
    Member

    @dangerdom

    Whoo! Thanks eexlebots! Worked perfectly for me.

    Lugarza: I had the same issue at first, phpMyAdmin shows a blank screen in firefox and safari. It worked for me in Opera, Camino, and IE.

    steve_magoo
    Member

    @steve_magoo

    Thank you eexlbots! Was getting very frustrated….

    aussiepunter
    Member

    @aussiepunter

    Thanks jmfolcik and eexlbots! Like others that was giving me a huge head ache.

    bigsquaredot
    Member

    @bigsquaredot

    This is an excellent thread. Thanks for the help gang. For those who have a blank screen when trying to use phpmyadmin, turn off all javascript in your browser and it should display.

    Valerie123
    Member

    @valerie123

    Thanks eexlebots for the step by step tutorial, I followed it and it works great! I’m so excited that it’s working again.

    Lugarza- Are you looking at PHPMYADMIN in Firefox? If so Try IE, it’s blank for me in Firefox, but works in IE. Perhaps that will work?

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Comments aren’t listed in the admin panel wordpress 2.5’ is closed to new replies.